summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-01-13 22:29:19 +0800
committerJason Zaman <perfinion@gentoo.org>2016-01-13 22:29:57 +0800
commit4e4dfb58cfe51ab6a48d40c7bd698c88b9268f27 (patch)
tree62b7a380e5192bc852a75b57f2bc62cb95fd9b35 /sys-auth/consolekit
parentMerge remote-tracking branch 'github/pr/624'. (diff)
downloadgentoo-4e4dfb58cfe51ab6a48d40c7bd698c88b9268f27.tar.gz
gentoo-4e4dfb58cfe51ab6a48d40c7bd698c88b9268f27.tar.bz2
gentoo-4e4dfb58cfe51ab6a48d40c7bd698c88b9268f27.zip
sys-auth/consolekit: version bump to 1.0.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/Manifest1
-rw-r--r--sys-auth/consolekit/consolekit-1.0.1.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/sys-auth/consolekit/Manifest b/sys-auth/consolekit/Manifest
index 0cd5d78aac6e..c546db61f78b 100644
--- a/sys-auth/consolekit/Manifest
+++ b/sys-auth/consolekit/Manifest
@@ -1,3 +1,4 @@
DIST ConsoleKit-0.4.6.tar.xz 366572 SHA256 b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c SHA512 54955e3e83778a9216846104da8762fd50a37190e209127dd5d211e2227da617e14f6f5c1359905396d299656e526d14e1187b28eaff7d0ae1d7563dc8d9b46d WHIRLPOOL ebf36b109b4c646d0b874f6b8e2ae9e2d190022ee9b6feff6cbb6b9203c80401c538cc3ca674fa7bde4f07e658d5460864e9784c1e0249d49b4784725a4e05c7
DIST ConsoleKit2-1.0.0.tar.bz2 1288174 SHA256 30b8026e62246593637bacf99ab9cbea18e7fea6ee07c45ae2a351912aacda4b SHA512 311cfc0aa945dcf50b4a98e1b19bd25cef84e89e4d849aa0b4b084b6cd8c52931a3af1c56243af00ff0a27b20230ab126de0cc0f08ea861f12a813399478bafa WHIRLPOOL fa834d0cf22a14844277c9f7333b89596c84368c1803fab119acc7799520a5078487351f23e3a66dd47000e09c447f70c03c2244601faf5236275641eeb3d040
+DIST ConsoleKit2-1.0.1.tar.bz2 1192681 SHA256 741c53321a0792b165f386c73c668af25615accab6d15983290103348a3ff00c SHA512 028e7347ff7293ebf3d08541d801e987cbc82fb31d98b67aa23e6dc28d00a422db9591c716c568320b6dde3fa01eb0b77b43c06d230f4bedd1085e078848a202 WHIRLPOOL c555281cd177ed243b1beb3d07d2988d029d8d89cac5242d12dcc37270d2d7adb1d503eaeba2f466964b589c4d10b8f2f014fef7067b535a7be9a360612d0485
DIST consolekit_0.4.6-4.debian.tar.gz 12192 SHA256 6d4dd5e13a76454b4bab27ab6b407718cd77616afd2b1af7cb8d947c1323b802 SHA512 f7fc5965b1f495d16a8ca167940431bc2569e9bde9e4a356b9c9ed00c2825db61da7b6db3d434d977fff72b3aaef30c455a365b9eba282a887a523753613b58f WHIRLPOOL 961a918c21259e24c68c7a5bf93964825b891ea207c088fecab61f81434012dc8925fca83b74518cfc9cf42f2c4a87eba7518c0829f663716ca0e11e38c856c9
diff --git a/sys-auth/consolekit/consolekit-1.0.1.ebuild b/sys-auth/consolekit/consolekit-1.0.1.ebuild
new file mode 100644
index 000000000000..4099a3a13e42
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-1.0.1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils linux-info pam
+
+MY_PN=ConsoleKit2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats"
+HOMEPAGE="https://github.com/ConsoleKit2/ConsoleKit2 http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${MY_P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_0.4.6-4.debian.tar.gz" # for logrotate file"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~amd64-linux ~arm ~hppa ~ia64-linux ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-linux"
+IUSE="acl cgroups debug doc kernel_linux pam policykit selinux test"
+
+COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
+ >=sys-devel/gettext-0.19
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ acl? (
+ sys-apps/acl:=
+ >=virtual/udev-200
+ )
+ cgroups? (
+ app-admin/cgmanager
+ >=sys-libs/libnih-1.0.2[dbus]
+ )
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/polkit-0.110 )"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/coreutils[acl?] )
+ selinux? ( sec-policy/selinux-consolekit )"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+QA_MULTILIB_PATHS="usr/lib/ConsoleKit/.*"
+
+pkg_setup() {
+ if use kernel_linux; then
+ # This is from https://bugs.gentoo.org/376939
+ use acl && CONFIG_CHECK="~TMPFS_POSIX_ACL"
+ # This is required to get login-session-id string with pam_ck_connector.so
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ XMLTO_FLAGS='--skip-validation' \
+ --libexecdir="${EPREFIX}"/usr/lib/ConsoleKit \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable pam pam-module) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable test docbook-docs) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable acl udev-acl) \
+ $(use_enable cgroups) \
+ $(use_enable test tests) \
+ --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
+ --with-pam-module-dir="$(getpam_mod_dir)" \
+ --with-xinitrc-dir=/etc/X11/xinit/xinitrc.d \
+ --without-systemdsystemunitdir
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dosym /usr/lib/ConsoleKit /usr/lib/${PN}
+
+ dodoc AUTHORS HACKING NEWS README TODO
+
+ newinitd "${FILESDIR}"/${PN}-1.0.0.initd consolekit
+
+ keepdir /usr/lib/ConsoleKit/run-seat.d
+ keepdir /usr/lib/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/log/ConsoleKit
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
+
+ prune_libtool_files --all # --all for pam_ck_connector.la
+
+ rm -rf "${ED}"/var/run || die # let the init script create the directory
+
+ insinto /etc/logrotate.d
+ newins "${WORKDIR}"/debian/${PN}.logrotate ${PN} #374513
+}
+
+pkg_postinst() {
+ elog "For suspend/hibernate support, please emerge"
+ elog " sys-power/pm-utils"
+}