summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 21:52:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 22:47:31 +0200
commit6e10b3ca8743a13cfdc600d2f8acdaaf2e220a26 (patch)
treebda68902a2b8bda61bd0f2a60f9b1a1ef903b5b7 /sys-auth/elogind
parentsys-auth/elogind: Drop 235.4 (diff)
downloadgentoo-6e10b3ca8743a13cfdc600d2f8acdaaf2e220a26.tar.gz
gentoo-6e10b3ca8743a13cfdc600d2f8acdaaf2e220a26.tar.bz2
gentoo-6e10b3ca8743a13cfdc600d2f8acdaaf2e220a26.zip
sys-auth/elogind: 238.1 version bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/Manifest1
-rw-r--r--sys-auth/elogind/elogind-238.1.ebuild120
-rw-r--r--sys-auth/elogind/files/elogind-238.1-docs.patch23
3 files changed, 144 insertions, 0 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
index c29a9a138fd2..aa45422b555f 100644
--- a/sys-auth/elogind/Manifest
+++ b/sys-auth/elogind/Manifest
@@ -1,3 +1,4 @@
DIST elogind-235.2.tar.gz 975652 BLAKE2B c568b5eec89da14f55211cf4405d96b4bb1ea274d1237739a92c4f3585a6181a3e17dc7ed2af5161c649cae2149b3bd25f4212cf5a304383b254e39d7aa0b378 SHA512 6fa9194e8c21fa3d3caf6f9499f772dbfe38b9d40d8a0fe43ee32ad4b2acd672a78798d00694d1e0d6107625f4f3f06b71e0a5466ed4be446d670f9bcd961313
DIST elogind-235.5.tar.gz 990321 BLAKE2B 03730f449e01ef74a92aa3313f59b93de3941425f95610e2d50dd6a0651682df5f2e245f9eeaeef5c5fd38300102fbccc980a55466ea12100e8904f126a5c44f SHA512 8f12c576f291fb9768e343e8257c74c62686f1a67b10170715b678e0431692cec7b6382102467dd2598a331c20d823d935128d5ff36f5b074dc02802ffec863c
DIST elogind-236.1.tar.gz 1050387 BLAKE2B d0d295210eb07374cae738f55b472d9410f68c9e7f318dd736b5fcb5c0409c3da144988d8042b1e3b103d34d7a02471b4e316a924c9b1640c605fc73972de3da SHA512 ab4989f4467ef001bb8b837035bee870beaf5ec5fa2389649bdcad2fe7bbf82691bfd3176cf9a3bf3b5c232c77210f431f2d38ebdbfd09f5a7868cd50e476c59
+DIST elogind-238.1.tar.gz 1074179 BLAKE2B 3041e9cfa0d454f653db164db8e59af4db5f3821bbb65cb5482d83f63e410612e121791f7ef3e08c9ac3940c7b6c7931df2b072ba452d2073c3e424e4dfe10c3 SHA512 ba0a74e9b9168b08a54b13ed500e9c713c48bb1648aa6064dbe666a96fa3fbd5b69447c35f686db3a1813476a5585be34b1ae13e3c9017eac8171b73f6311c4c
diff --git a/sys-auth/elogind/elogind-238.1.ebuild b/sys-auth/elogind/elogind-238.1.ebuild
new file mode 100644
index 000000000000..c532686d9faa
--- /dev/null
+++ b/sys-auth/elogind/elogind-238.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info meson pam udev xdg-utils
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+acl debug doc +pam +policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+DOCS=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ local cgroupmode="legacy"
+
+ if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
+ cgroupmode="hybrid"
+ elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
+ cgroupmode="unified"
+ fi
+
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ -Dpamlibdir=$(getpam_mod_dir)
+ -Dudevrulesdir="$(get_udevdir)"/rules.d
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ -Drootlibdir="${EPREFIX}"/$(get_libdir)
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
+ -Drootprefix="${EPREFIX}/"
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
+ -Dman=auto
+ -Dsmack=true
+ -Dcgroup-controller=openrc
+ -Ddefault-hierarchy=${cgroupmode}
+ -Ddefault-kill-user-processes=false
+ -Dacl=$(usex acl true false)
+ -Ddebug=$(usex debug elogind false)
+ --buildtype $(usex debug debug release)
+ -Dhtml=$(usex doc auto false)
+ -Dpam=$(usex pam true false)
+ -Dselinux=$(usex selinux true false)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
+ meson_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
+ elog "elogind is currently started from boot runlevel."
+ elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
+ ewarn "elogind is currently started from default runlevel."
+ ewarn "Please remove elogind from the default runlevel and"
+ ewarn "add it to the boot runlevel by:"
+ ewarn "# rc-update del elogind default"
+ ewarn "# rc-update add elogind boot"
+ else
+ ewarn "elogind is currently not started from any runlevel."
+ ewarn "You may add it to the boot runlevel by:"
+ ewarn "# rc-update add elogind boot"
+ fi
+}
diff --git a/sys-auth/elogind/files/elogind-238.1-docs.patch b/sys-auth/elogind/files/elogind-238.1-docs.patch
new file mode 100644
index 000000000000..2288ddfecb32
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-238.1-docs.patch
@@ -0,0 +1,23 @@
+--- a/meson.build 2018-06-25 16:41:00.000000000 +0200
++++ b/meson.build 2018-06-30 21:45:52.139755680 +0200
+@@ -2928,11 +2928,6 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+- 'NEWS',
+- 'README',
+- 'doc/CODING_STYLE',
+ #if 0 /// irrelevant for elogind
+ # 'doc/DISTRO_PORTING',
+ # 'doc/ENVIRONMENT.md',
+@@ -2941,8 +2936,6 @@
+ # 'doc/TRANSLATORS',
+ # 'doc/UIDS-GIDS.md',
+ #endif // 0
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+- install_dir : docdir)
+
+ #if 0 /// UNNEEDED by elogind
+ # meson.add_install_script('sh', '-c', mkdir_p.format(systemdstatedir))