summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-08-15 12:33:57 -0400
committerCraig Andrews <candrews@gentoo.org>2017-09-07 09:14:14 -0400
commit6f6c7207eb9bd0da8a2145667a1f8f8b543b121d (patch)
treee5fd0298a29826d76eebd18bd8fb9c1923186aa7 /sys-auth/google-authenticator
parentsys-auth/google-authenticator: update metadata.xml to point to the correct gi... (diff)
downloadgentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.tar.gz
gentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.tar.bz2
gentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.zip
sys-auth/google-authenticator: bump to 1.04, update -9999, EAPI=6
Gentoo-bug: 619346 Package-Manager: Portage-2.3.7, Repoman-2.3.3 Closes #5430
Diffstat (limited to 'sys-auth/google-authenticator')
-rw-r--r--sys-auth/google-authenticator/Manifest1
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.04.ebuild49
-rw-r--r--sys-auth/google-authenticator/google-authenticator-9999.ebuild37
3 files changed, 58 insertions, 29 deletions
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
index ddc10ac8ae5c..2ef77cc79bdc 100644
--- a/sys-auth/google-authenticator/Manifest
+++ b/sys-auth/google-authenticator/Manifest
@@ -1 +1,2 @@
DIST google-authenticator-1.01_pre20160307231538.tar.xz 255316 SHA256 41bdc47278903bc33e87c8b4da6f9fe5b526a2f780790d4f83bb67634f3f53b0 SHA512 cee3898b7afec54079968ff0690f076b78512b0b2c982ef5bedb2d6c5850b103c80191caa4b172069a83eb4d15ea4fce5b3f5eefdb36aa0426d985ba29736108 WHIRLPOOL 90e6439c632ccf4c791d988304b2e1cb7753f03ec03678b7f83946bdefc2bf1ca6d81538c484bc73561060fc7a7d80518845e13c49f6b5d943233e0123b2a1c8
+DIST google-authenticator-1.04.tar.gz 54019 SHA256 8284cc046be436513d9d4bbb1285017327edbcc32f6f620c47e7e889c4b966ef SHA512 e4b8ad74301312e17edd0a7f25257086fd805c8d5215b06b71d96e9a64a71b2c87d0c5a532d9eca21d6d67e30c02c2c2c77dbd338a2f49af25c32dcd355ee98e WHIRLPOOL a170c155125c6ee51b9aac346a36fe1ed7efac9d215251cb2c14fb462e3e03643cfdc85aa393e491223f1050dc514356ce8199dece327c45368481131b9b1de7
diff --git a/sys-auth/google-authenticator/google-authenticator-1.04.ebuild b/sys-auth/google-authenticator/google-authenticator-1.04.ebuild
new file mode 100644
index 000000000000..e3259cba968a
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.04.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}
diff --git a/sys-auth/google-authenticator/google-authenticator-9999.ebuild b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
index b637ffb38586..e3259cba968a 100644
--- a/sys-auth/google-authenticator/google-authenticator-9999.ebuild
+++ b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit multilib
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/google/${PN}.git"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
inherit git-r3 autotools
- S="${WORKDIR}/${P}/libpam"
else
- MY_P=${P%_pre*}
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
fi
DESCRIPTION="PAM Module for two step verification via mobile platform"
-HOMEPAGE="https://github.com/google/google-authenticator"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
LICENSE="Apache-2.0"
SLOT="0"
@@ -27,37 +25,18 @@ DEPEND="virtual/pam"
RDEPEND="${DEPEND}"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ default
+ if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
}
-src_configure() {
- # We might want to use getpam_mod_dir from pam eclass,
- # but the build already appends "/security" for us.
- econf \
- --docdir="\$(datarootdir)/doc/${PF}" \
- --htmldir='$(docdir)/html' \
- --libdir="/$(get_libdir)"
-}
-
src_compile() {
default
-
- if [[ ${PV} == "9999" ]] ; then
- local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u "+%Y%m%d%H%M%S")
- emake dist
-
- local otar=$(echo ${PN}-*.tar.gz)
- local ntar="${otar%.tar.gz}_pre${stamp}.tar.xz"
- zcat "${otar}" | xz > "${ntar}"
- fi
}
src_install() {
default
- # Punt the pam module libtool archive.
- find "${ED}" -name '*.la' -delete
}
pkg_postinst() {