summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-10 22:41:48 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-10 22:41:48 +0200
commitbc485e300f416a29765fc1a5bba0434027a4e6f7 (patch)
treedd01e77bc1af3b9569b68911489cd432d4bf1ec7 /sys-auth/libfprint/libfprint-0.6.0.ebuild
parentdev-go/go-tools: remove old snapshot (diff)
downloadgentoo-bc485e300f416a29765fc1a5bba0434027a4e6f7.tar.gz
gentoo-bc485e300f416a29765fc1a5bba0434027a4e6f7.tar.bz2
gentoo-bc485e300f416a29765fc1a5bba0434027a4e6f7.zip
sys-auth/libfprint: add support for vfs0050 scanner (bug 531698).
Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-auth/libfprint/libfprint-0.6.0.ebuild')
-rw-r--r--sys-auth/libfprint/libfprint-0.6.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-auth/libfprint/libfprint-0.6.0.ebuild b/sys-auth/libfprint/libfprint-0.6.0.ebuild
index 79ebb65f33fc..cb31c9d42881 100644
--- a/sys-auth/libfprint/libfprint-0.6.0.ebuild
+++ b/sys-auth/libfprint/libfprint-0.6.0.ebuild
@@ -9,12 +9,14 @@ inherit autotools eutils udev vcs-snapshot
MY_PV="V_${PV//./_}"
DESCRIPTION="library to add support for consumer fingerprint readers"
HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
-SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2
+ https://github.com/zemen/libfprint/commit/23f1ef96dc612f80e5d7c9277b18d5973fc65cf6.patch -> ${P}_vfs0050.patch
+ https://github.com/zemen/libfprint/commit/f1fdd71613a483e054cd11e19bdcfb49c95fa2cb.patch -> ${P}_driver_name.patch"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="debug static-libs"
+IUSE="debug static-libs vanilla"
RDEPEND="virtual/libusb:1
dev-libs/glib:2
@@ -24,6 +26,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ if ! use vanilla ; then
+ epatch "${DISTDIR}"/${P}_driver_name.patch
+ epatch "${DISTDIR}"/${P}_vfs0050.patch
+ # drop area with nested C comment
+ sed -e '341,381d' -i ${PN}/drivers/vfs0050.h
+ fi
+
# upeke2 and fdu2000 were missing from all_drivers.
sed -e '/^all_drivers=/s:"$: upeke2 fdu2000":' \
-i configure.ac || die