summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:50:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:51:15 +0200
commitb1c1e8e9061dacd956220e2078fc0a933e7f3040 (patch)
tree2bde2be7fb98c38b6ca581672714a422bd563e7f /sys-auth/libnss-compat/libnss-compat-1.2.ebuild
parentsys-libs/glibc: Remove old (diff)
downloadgentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.tar.gz
gentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.tar.bz2
gentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.zip
sys-auth/libnss-compat: Add separate libnss_compat module, bug 627338
Only for people who really, really, really need it... Bug: https://bugs.gentoo.org/627338 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sys-auth/libnss-compat/libnss-compat-1.2.ebuild')
-rw-r--r--sys-auth/libnss-compat/libnss-compat-1.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-auth/libnss-compat/libnss-compat-1.2.ebuild b/sys-auth/libnss-compat/libnss-compat-1.2.ebuild
new file mode 100644
index 000000000000..9d01d095eb87
--- /dev/null
+++ b/sys-auth/libnss-compat/libnss-compat-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="NSS module to provide compat entry support"
+HOMEPAGE="https://github.com/thkukuk/libnss_compat"
+SRC_URI="https://github.com/thkukuk/libnss_compat/archive/libnss_compat-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >net-libs/libnsl-0:0=[${MULTILIB_USEDEP}]
+ net-libs/libtirpc:0=[${MULTILIB_USEDEP}]
+ !<sys-libs/glibc-2.26
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+S=${WORKDIR}/libnss_compat-libnss_compat-${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}