summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 17:55:21 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 18:08:56 +0200
commite1b482efe55f94b4a6a5741ad257349eb2c165c6 (patch)
tree544ea2b01e7d841f767004e5391de718f9030d11 /sys-auth/nss-mdns
parentapp-arch/plzip: Bump to 1.8 (diff)
downloadgentoo-e1b482efe55f94b4a6a5741ad257349eb2c165c6.tar.gz
gentoo-e1b482efe55f94b4a6a5741ad257349eb2c165c6.tar.bz2
gentoo-e1b482efe55f94b4a6a5741ad257349eb2c165c6.zip
sys-auth/nss-mdns: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-auth/nss-mdns')
-rw-r--r--sys-auth/nss-mdns/Manifest1
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.14.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/nss-mdns/Manifest b/sys-auth/nss-mdns/Manifest
index b7a8af7b6309..6ca2a4263e78 100644
--- a/sys-auth/nss-mdns/Manifest
+++ b/sys-auth/nss-mdns/Manifest
@@ -1 +1,2 @@
DIST nss-mdns-0.13.tar.gz 380261 BLAKE2B 555b7b9df8ff15da423712fac04ccbc303395d38a07121906cf31871a8684c71e43809b80674a489d87397902a33f4d19b0ae49a4c384290bad227a24880476f SHA512 f1b379111fb758323179ea3e447d754e934308940b11a8402dfb6033264940d831266d15ae1ee0badfecd5cdc7f589b42e4363dfc058f5e62026017d97eb0a3b
+DIST nss-mdns-0.14.1.tar.gz 369978 BLAKE2B d1539ff5c1830a120d6ed4fafa36aa6effb9bb973b275317f5d8f4515aad7d2f69f095296a6b95ad8cc19d6eeb076b19b7987c5eabf29fd21f54cfe4a652ed3a SHA512 7c06b984443881a6c0a1f850ee33f14780562cc6168fe1cda176303eb799ece510d51d3830928616723bb95250ad6462978cd8b857f2b79d87116da2c1aeaa5e
diff --git a/sys-auth/nss-mdns/nss-mdns-0.14.1.ebuild b/sys-auth/nss-mdns/nss-mdns-0.14.1.ebuild
new file mode 100644
index 000000000000..4a8a3740c186
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.14.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="https://github.com/lathiat/nss-mdns"
+SRC_URI="https://github.com/lathiat/nss-mdns/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.11[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myconf=(
+ # $(localstatedir)/run/... is used to locate avahi-daemon socket
+ --localstatedir=/var
+
+ $(use_enable test tests)
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc *.md
+
+ insinto /etc
+ doins "${FILESDIR}"/mdns.allow
+}
+
+pkg_postinst() {
+ ewarn "You have to modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf."
+ ewarn "An example line looks like:"
+ ewarn "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow."
+}