summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-21 22:08:17 +0000
committerSam James <sam@gentoo.org>2022-02-21 22:08:17 +0000
commit4976006ce85f935fbbeb96020507eda1aadedf52 (patch)
tree41e7a4f527e7bf486b9537d3f803a5f6d26b5e29 /sys-auth/oath-toolkit
parentdev-libs/expat: stable 2.4.6 for hppa/sparc, bug #833633 (diff)
downloadgentoo-4976006ce85f935fbbeb96020507eda1aadedf52.tar.gz
gentoo-4976006ce85f935fbbeb96020507eda1aadedf52.tar.bz2
gentoo-4976006ce85f935fbbeb96020507eda1aadedf52.zip
sys-auth/oath-toolkit: add ICU dependency
Closes: https://bugs.gentoo.org/833850 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth/oath-toolkit')
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2-r2.ebuild (renamed from sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r2.ebuild
index e6e4f650cf44..038be19846c7 100644
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,14 +7,15 @@ inherit pam autotools
DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
HOMEPAGE="http://www.nongnu.org/oath-toolkit/"
SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
-LICENSE="GPL-3 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86"
IUSE="pam pskc static-libs test"
RESTRICT="!test? ( test )"
RDEPEND="
+ dev-libs/icu:=
pam? ( sys-libs/pam )
pskc? ( dev-libs/xmlsec )"
DEPEND="${RDEPEND}
@@ -57,6 +58,13 @@ src_configure() {
$(use_enable static-libs static)
}
+src_test() {
+ # without keep-going, it will bail out after the first testsuite failure,
+ # skipping the other testsuites. as they are mostly independant, this sucks.
+ emake --keep-going check
+ [ $? -ne 0 ] && die "At least one testsuite failed"
+}
+
src_install() {
default
find "${ED}" -name '*.la' -type f -delete || die
@@ -67,10 +75,3 @@ src_install() {
doman pskctool/pskctool.1
fi
}
-
-src_test() {
- # without keep-going, it will bail out after the first testsuite failure,
- # skipping the other testsuites. as they are mostly independant, this sucks.
- emake --keep-going check
- [ $? -ne 0 ] && die "At least one testsuite failed"
-}