summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-26 22:30:43 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-26 22:49:59 +0100
commit775908576d06ed674ea1cb8d86ef524845db90b0 (patch)
tree8494ac0fa431c9739f879754f142d59df7a2e07f /sys-auth/pam_yubico/pam_yubico-2.24.ebuild
parentdev-python/rsa: Clean up vulnerable versions. (diff)
downloadgentoo-775908576d06ed674ea1cb8d86ef524845db90b0.tar.gz
gentoo-775908576d06ed674ea1cb8d86ef524845db90b0.tar.bz2
gentoo-775908576d06ed674ea1cb8d86ef524845db90b0.zip
sys-auth/pam_yubico: Bump to version 2.24
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-auth/pam_yubico/pam_yubico-2.24.ebuild')
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.24.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/pam_yubico-2.24.ebuild b/sys-auth/pam_yubico/pam_yubico-2.24.ebuild
new file mode 100644
index 000000000000..212e18af0eac
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+
+RDEPEND="
+ virtual/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ #prune_libtool_files #why doesn't this work?
+ find "${D}" -name '*.la' -delete || die
+}