summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-03 11:55:26 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-03 11:55:26 +0200
commit3b6864f38b6121ce01254e367dbd44cd3e9838a2 (patch)
tree56bb8929f607a17e99da7b9e5673b033678870b5 /sys-auth/pambase
parentwww-client/opera: Version 69.0.3686.49 (diff)
downloadgentoo-3b6864f38b6121ce01254e367dbd44cd3e9838a2.tar.gz
gentoo-3b6864f38b6121ce01254e367dbd44cd3e9838a2.tar.bz2
gentoo-3b6864f38b6121ce01254e367dbd44cd3e9838a2.zip
sys-auth/pambase: Fix USE="native-symlinks"
Closes: https://bugs.gentoo.org/719212 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Suggested-by: Sergei Trofimovich <slyfox@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth/pambase')
-rw-r--r--sys-auth/pambase/pambase-20190402.ebuild5
-rw-r--r--sys-auth/pambase/pambase-20191128.ebuild5
-rw-r--r--sys-auth/pambase/pambase-20200304.ebuild5
-rw-r--r--sys-auth/pambase/pambase-20200618.ebuild5
4 files changed, 16 insertions, 4 deletions
diff --git a/sys-auth/pambase/pambase-20190402.ebuild b/sys-auth/pambase/pambase-20190402.ebuild
index 561f79c02e7a..6f2cd170ef2e 100644
--- a/sys-auth/pambase/pambase-20190402.ebuild
+++ b/sys-auth/pambase/pambase-20190402.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
@@ -62,6 +64,7 @@ src_compile() {
emake \
GIT=true \
+ CPP="$(tc-getPROG CPP cpp)" \
$(use_var debug) \
$(use_var cracklib) \
$(use_var passwdqc) \
@@ -83,5 +86,5 @@ src_compile() {
src_test() { :; }
src_install() {
- emake GIT=true DESTDIR="${ED}" install
+ emake GIT=true CPP="$(tc-getPROG CPP cpp)" DESTDIR="${ED}" install
}
diff --git a/sys-auth/pambase/pambase-20191128.ebuild b/sys-auth/pambase/pambase-20191128.ebuild
index c2f09b9e78a1..999ff2a32d5f 100644
--- a/sys-auth/pambase/pambase-20191128.ebuild
+++ b/sys-auth/pambase/pambase-20191128.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
@@ -58,6 +60,7 @@ src_compile() {
emake \
GIT=true \
+ CPP="$(tc-getPROG CPP cpp)" \
$(use_var debug) \
$(use_var LIBCAP caps) \
$(use_var cracklib) \
@@ -79,5 +82,5 @@ src_compile() {
src_test() { :; }
src_install() {
- emake GIT=true DESTDIR="${ED}" install
+ emake GIT=true CPP="$(tc-getPROG CPP cpp)" DESTDIR="${ED}" install
}
diff --git a/sys-auth/pambase/pambase-20200304.ebuild b/sys-auth/pambase/pambase-20200304.ebuild
index c2f09b9e78a1..999ff2a32d5f 100644
--- a/sys-auth/pambase/pambase-20200304.ebuild
+++ b/sys-auth/pambase/pambase-20200304.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
@@ -58,6 +60,7 @@ src_compile() {
emake \
GIT=true \
+ CPP="$(tc-getPROG CPP cpp)" \
$(use_var debug) \
$(use_var LIBCAP caps) \
$(use_var cracklib) \
@@ -79,5 +82,5 @@ src_compile() {
src_test() { :; }
src_install() {
- emake GIT=true DESTDIR="${ED}" install
+ emake GIT=true CPP="$(tc-getPROG CPP cpp)" DESTDIR="${ED}" install
}
diff --git a/sys-auth/pambase/pambase-20200618.ebuild b/sys-auth/pambase/pambase-20200618.ebuild
index 5f9cdff6bc2a..2be0b99f0442 100644
--- a/sys-auth/pambase/pambase-20200618.ebuild
+++ b/sys-auth/pambase/pambase-20200618.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
@@ -57,6 +59,7 @@ src_compile() {
emake \
GIT=true \
+ CPP="$(tc-getPROG CPP cpp)" \
$(use_var debug) \
$(use_var LIBCAP caps) \
$(use_var passwdqc) \
@@ -77,5 +80,5 @@ src_compile() {
src_test() { :; }
src_install() {
- emake GIT=true DESTDIR="${ED}" install
+ emake GIT=true CPP="$(tc-getPROG CPP cpp)" DESTDIR="${ED}" install
}