summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-03-13 14:01:23 +0100
committerMarek Szuba <marecki@gentoo.org>2020-03-13 14:27:09 +0100
commitfc5f59cf4c173ffd522ffd05c5fb39c048e58f29 (patch)
tree8f726ab35a928b0b8752eba6e0969648e21be727 /sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch
parentnet-misc/networkmanager: bump to 1.22.10 (diff)
downloadgentoo-fc5f59cf4c173ffd522ffd05c5fb39c048e58f29.tar.gz
gentoo-fc5f59cf4c173ffd522ffd05c5fb39c048e58f29.tar.bz2
gentoo-fc5f59cf4c173ffd522ffd05c5fb39c048e58f29.zip
sys-auth/rtkit: bump to 0.12
While I haven't heard anything official about Jan Steffens having taken over rtkit maintenance from Lennart, if Debian* approves it's good enough for me. * as well as other distros Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch')
-rw-r--r--sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch b/sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch
new file mode 100644
index 000000000000..9d61f4e5685c
--- /dev/null
+++ b/sys-auth/rtkit/files/rtkit-0.12_libsystemd_optional.patch
@@ -0,0 +1,63 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -116,7 +116,15 @@
+ AC_SEARCH_LIBS([cap_init], [cap])
+
+ PKG_CHECK_MODULES(DBUS, dbus-1)
+-PKG_CHECK_MODULES(LIBSYSTEMD, libsystemd)
++
++AC_ARG_ENABLE(systemd-integration,
++ AS_HELP_STRING([--enable-systemd-integration], [use the sd-daemon API to communicate with systemd]),
++ [enable_libsystemd=$enableval],
++ [enable_libsystemd=yes])
++if test "x${enable_libsystemd}" != "xno"; then
++ PKG_CHECK_MODULES(LIBSYSTEMD, libsystemd)
++ AC_DEFINE([HAVE_LIBSYSTEMD], [1], [Define to 1 if you have libsystemd and its header files])
++fi
+
+ AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+@@ -142,5 +150,6 @@
+ localstatedir: ${localstatedir}
+ Compiler: ${CC}
+ CFLAGS: ${CFLAGS}
++ systemd integration: ${enable_libsystemd}
+ systemd unit directory: ${systemdsystemunitdir}
+ "
+--- a/rtkit-daemon.c
++++ b/rtkit-daemon.c
+@@ -50,7 +50,10 @@
+ #include <dirent.h>
+ #include <syslog.h>
+ #include <grp.h>
++
++#ifdef HAVE_LIBSYSTEMD
+ #include <systemd/sd-daemon.h>
++#endif
+
+ #include "rtkit.h"
+
+@@ -1432,11 +1435,13 @@
+ n_total_processes,
+ n_users);
+
++#ifdef HAVE_LIBSYSTEMD
+ sd_notifyf(0,
+ "STATUS=Supervising %u threads of %u processes of %u users.",
+ n_total_threads,
+ n_total_processes,
+ n_users);
++#endif
+
+ finish:
+ if (r) {
+@@ -2304,7 +2309,9 @@
+
+ syslog(LOG_DEBUG, "Running.\n");
+
++#ifdef HAVE_LIBSYSTEMD
+ sd_notify(0, "STATUS=Running.");
++#endif
+
+ dbus_connection_set_exit_on_disconnect(bus, FALSE);
+