summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-10-29 16:56:15 +0200
committerUlrich Müller <ulm@gentoo.org>2016-10-29 16:56:15 +0200
commitf1462b3a2246f5c69a96578f8fdcafa5b1c96b97 (patch)
tree7eecae4cde27688490df132b5229af85a255c3b5 /sys-auth/skey
parentdev-ruby/priorityqueue: Add ruby23 (diff)
downloadgentoo-f1462b3a2246f5c69a96578f8fdcafa5b1c96b97.tar.gz
gentoo-f1462b3a2246f5c69a96578f8fdcafa5b1c96b97.tar.bz2
gentoo-f1462b3a2246f5c69a96578f8fdcafa5b1c96b97.zip
sys-auth/skey: Fix build with musl libc.
Bug: 597646 Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-auth/skey')
-rw-r--r--sys-auth/skey/Manifest1
-rw-r--r--sys-auth/skey/skey-1.1.5-r11.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sys-auth/skey/Manifest b/sys-auth/skey/Manifest
index 7e0a61cae5aa..3e27c3e703cc 100644
--- a/sys-auth/skey/Manifest
+++ b/sys-auth/skey/Manifest
@@ -1,2 +1,3 @@
DIST skey-1.1.5-patches-5.tar.xz 33972 SHA256 845c9c71b8d69bf20854412536e736a7e6a6d07ea6abbc02ed10229207e4582e SHA512 5be8cb520311799f4ee105d4e6ec6bf2a9e76a1e49df632cf85b7e9e1126ff876551231b06d26911ca36b834b48ebdd1a9e3f1f889df3d1cee4989ed24c0a7fd WHIRLPOOL f78f30c7882d4c18a0d44139ca107413eb1d6db9f82fb1b570c535c28225dc4b5ed7450be17e9b23a4efa851ccc1d3f5bc19f7d5288eb75bb11ba2db2f0ec1ae
+DIST skey-1.1.5-patches-6.tar.xz 34108 SHA256 b63423380c3c60b95f213187aa2522b49da1b8227cde2decc405caa126fef05e SHA512 2c807675cdd6b800f03427d79d616f59ac9d4d438221913328ec92e5dd13af185f74a24e17d36af8d49a51c4ecc5b24ef198489acce416d829e8aacf5d3c208a WHIRLPOOL 8841611ff50aa8509b1d94665f87d9f0888d39958a5385e8fb5b044228bcc251565449629588d92531771d910e48b7a0ce6998f86a131a145ed5c288fc828133
DIST skey-1.1.5.tar.bz2 61911 SHA256 e21bcb7c618c0bc87a72d8f0f097d7517fffa4e881a0f295ee1ce2a7dccf4aef SHA512 4cbddc7e31134d5e23801a9b07de0d05c8357aaa8dddfb8426fceead3f54e539f77204f78a08b2a93890ef2f4f807a2208080f58f80818afa1b8cd4884b1fb37 WHIRLPOOL abf141fd679deeaee3f3883cd3076620c84e8775ecacc8f87d561c1812beae55299989f37ec331633bac29e25b4b8d145dc590ef119c73a137d8790815bb13f2
diff --git a/sys-auth/skey/skey-1.1.5-r11.ebuild b/sys-auth/skey/skey-1.1.5-r11.ebuild
new file mode 100644
index 000000000000..9dfc00e4a6c0
--- /dev/null
+++ b/sys-auth/skey/skey-1.1.5-r11.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="Linux Port of OpenBSD Single-key Password System"
+HOMEPAGE="http://www.openbsd.org/faq/faq8.html#SKey"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~ulm/distfiles/${P}-patches-6.tar.xz"
+
+LICENSE="BSD MIT RSA BEER-WARE"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/perl
+ app-arch/xz-utils"
+RDEPEND="dev-lang/perl
+ virtual/perl-Time-Local
+ sys-libs/cracklib"
+
+PATCHES="../patch"
+
+src_configure() {
+ tc-export CC
+ econf --sysconfdir=/etc/skey
+}
+
+src_install() {
+ into /
+ dolib.so libskey.so{.${PV},.${PV%.*},.${PV%%.*},}
+
+ into /usr
+ dobin skey skeyinit skeyinfo
+ newbin skeyaudit.sh skeyaudit
+ newsbin skeyprune.pl skeyprune
+
+ dosym skey /usr/bin/otp-md4
+ dosym skey /usr/bin/otp-md5
+ dosym skey /usr/bin/otp-sha1
+
+ if use static-libs; then
+ dolib.a libskey.a
+ gen_usr_ldscript libskey.so
+ fi
+
+ doman skey.1 skeyaudit.1 skeyinfo.1 skeyinit.1 skey.3 skeyprune.8
+
+ insinto /usr/include
+ doins skey.h
+
+ keepdir /etc/skey
+
+ # only root needs to have access to these files.
+ fperms go-rx /etc/skey
+
+ # skeyinit and skeyinfo must be suid root so users
+ # can generate their passwords.
+ fperms u+s,go-r /usr/bin/skeyinit /usr/bin/skeyinfo
+
+ dodoc README CHANGES
+
+ DOC_CONTENTS="For an introduction into using s/key authentication,
+ take a look at the EXAMPLES section from the skey(1) manpage."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ # do not include /etc/skey/skeykeys in the package, as quickpkg
+ # may package sensitive information.
+ # This also fixes the etc-update issue with #64974.
+
+ # skeyinit will not function if this file is not present.
+ touch /etc/skey/skeykeys
+
+ # these permissions are applied by the skey system if missing.
+ chmod 0600 /etc/skey/skeykeys
+
+ readme.gentoo_print_elog
+}