summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/sssd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/sssd/files')
-rw-r--r--sys-auth/sssd/files/0001_add_pthread_to_fix_as-needed.patch36
-rw-r--r--sys-auth/sssd/files/0002_allow_xdm_openrc.patch19
-rw-r--r--sys-auth/sssd/files/0003_new_krb5.patch46
-rw-r--r--sys-auth/sssd/files/allow_xdm.patch19
-rw-r--r--sys-auth/sssd/files/sssd21
-rw-r--r--sys-auth/sssd/files/sssd-1.13.0-fix-init.patch28
-rw-r--r--sys-auth/sssd/files/sssd-1.9.6-fix-init.patch31
-rw-r--r--sys-auth/sssd/files/sssd.conf4
-rw-r--r--sys-auth/sssd/files/sssd.service15
9 files changed, 219 insertions, 0 deletions
diff --git a/sys-auth/sssd/files/0001_add_pthread_to_fix_as-needed.patch b/sys-auth/sssd/files/0001_add_pthread_to_fix_as-needed.patch
new file mode 100644
index 000000000000..00769a00597d
--- /dev/null
+++ b/sys-auth/sssd/files/0001_add_pthread_to_fix_as-needed.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -313,7 +313,8 @@
+ $(DHASH_LIBS) \
+ $(SSS_CRYPT_LIBS) \
+ $(OPENLDAP_LIBS) \
+- $(TDB_LIBS)
++ $(TDB_LIBS) \
++ -lpthread
+
+ PYTHON_BINDINGS_LIBS = \
+ $(TALLOC_LIBS) \
+@@ -338,7 +339,8 @@
+ $(COLLECTION_LIBS) \
+ $(DHASH_LIBS) \
+ $(OPENLDAP_LIBS) \
+- $(TDB_LIBS)
++ $(TDB_LIBS) \
++ -lpthread
+
+ if BUILD_SELINUX
+ PYTHON_BINDINGS_LIBS += $(SELINUX_LIBS)
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,8 @@
+ AM_PROG_CC_C_O
+ AC_DISABLE_STATIC
+ AC_PROG_INSTALL
+-AC_PROG_LIBTOOL
++LT_INIT
++AM_PROG_AR
+ AC_CONFIG_MACRO_DIR([m4])
+ AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.14])
diff --git a/sys-auth/sssd/files/0002_allow_xdm_openrc.patch b/sys-auth/sssd/files/0002_allow_xdm_openrc.patch
new file mode 100644
index 000000000000..40d64cbf41ff
--- /dev/null
+++ b/sys-auth/sssd/files/0002_allow_xdm_openrc.patch
@@ -0,0 +1,19 @@
+--- src/sysv/gentoo/sssd.old 2011-08-02 23:14:48.000000000 +0300
++++ src/sysv/gentoo/sssd 2011-08-24 12:15:18.413929409 +0300
+@@ -1,13 +1,13 @@
+ #!/sbin/runscript
+
+ depend(){
+- need localmount netmount clock
+- use syslog
++ need localmount netmount clock nscd
++ use syslog xdm
+ }
+
+ start(){
+ ebegin "Starting sssd"
+- start-stop-daemon --start --exec /usr/sbin/sssd -- -D
++ start-stop-daemon --start --exec /usr/sbin/sssd -- -Df
+ eend ${?}
+ }
+
diff --git a/sys-auth/sssd/files/0003_new_krb5.patch b/sys-auth/sssd/files/0003_new_krb5.patch
new file mode 100644
index 000000000000..03a7c744f2ae
--- /dev/null
+++ b/sys-auth/sssd/files/0003_new_krb5.patch
@@ -0,0 +1,46 @@
+From 4e78fab6a1b2e9653a7959cbdb7d54bb750041d0 Mon Sep 17 00:00:00 2001
+From: Jakub Hrozek <jhrozek@redhat.com>
+Date: Mon, 04 Feb 2013 16:30:48 +0000
+Subject: krb5: include backwards compatible declaration of krb5_trace_info
+
+krb5-1.10 used to include "struct krb5_trace_info", now krb5-1.11
+includes a "krb5_trace_info" typedefed from "struct _krb5_trace_info".
+
+Do the same in the SSSD to allow compiling with both 1.10 and 1.11.
+---
+diff --git a/src/external/krb5.m4 b/src/external/krb5.m4
+index 5bc8711..f1679a1 100644
+--- a/src/external/krb5.m4
++++ b/src/external/krb5.m4
+@@ -37,7 +37,7 @@ SAVE_LIBS=$LIBS
+ CFLAGS="$CFLAGS $KRB5_CFLAGS"
+ LIBS="$LIBS $KRB5_LIBS"
+ AC_CHECK_HEADERS([krb5.h krb5/krb5.h])
+-AC_CHECK_TYPES([krb5_ticket_times, krb5_times], [], [],
++AC_CHECK_TYPES([krb5_ticket_times, krb5_times, krb5_trace_info], [], [],
+ [ #ifdef HAVE_KRB5_KRB5_H
+ #include <krb5/krb5.h>
+ #else
+diff --git a/src/util/sss_krb5.c b/src/util/sss_krb5.c
+index bb61d10..ab0344c 100644
+--- a/src/util/sss_krb5.c
++++ b/src/util/sss_krb5.c
+@@ -1001,9 +1001,15 @@ sss_krb5_residual_check_type(const char *full_location,
+ }
+
+ #ifdef HAVE_KRB5_SET_TRACE_CALLBACK
++
++#ifndef HAVE_KRB5_TRACE_INFO
++/* krb5-1.10 had struct krb5_trace_info, 1.11 has type named krb5_trace_info */
++typedef struct krb5_trace_info krb5_trace_info;
++#endif /* HAVE_KRB5_TRACE_INFO */
++
+ static void
+ sss_child_krb5_trace_cb(krb5_context context,
+- const struct krb5_trace_info *info, void *data)
++ const krb5_trace_info *info, void *data)
+ {
+ if (info == NULL) {
+ /* Null info means destroy the callback data. */
+--
+cgit v0.9.1
diff --git a/sys-auth/sssd/files/allow_xdm.patch b/sys-auth/sssd/files/allow_xdm.patch
new file mode 100644
index 000000000000..40d64cbf41ff
--- /dev/null
+++ b/sys-auth/sssd/files/allow_xdm.patch
@@ -0,0 +1,19 @@
+--- src/sysv/gentoo/sssd.old 2011-08-02 23:14:48.000000000 +0300
++++ src/sysv/gentoo/sssd 2011-08-24 12:15:18.413929409 +0300
+@@ -1,13 +1,13 @@
+ #!/sbin/runscript
+
+ depend(){
+- need localmount netmount clock
+- use syslog
++ need localmount netmount clock nscd
++ use syslog xdm
+ }
+
+ start(){
+ ebegin "Starting sssd"
+- start-stop-daemon --start --exec /usr/sbin/sssd -- -D
++ start-stop-daemon --start --exec /usr/sbin/sssd -- -Df
+ eend ${?}
+ }
+
diff --git a/sys-auth/sssd/files/sssd b/sys-auth/sssd/files/sssd
new file mode 100644
index 000000000000..dbf7850227c4
--- /dev/null
+++ b/sys-auth/sssd/files/sssd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+command="/usr/sbin/sssd"
+command_args="${SSSD_OPTIONS} -D"
+start_stop_daemon_args="--quiet"
+description="System Security Services Daemon"
+
+depend(){
+ need localmount clock
+ use syslog xdm
+}
+
+if [ "${RC_VERSION:-0}" = "0" ]; then
+ start() {
+ eerror "This script cannot be used for baselayout-1."
+ return 1
+ }
+fi
diff --git a/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch b/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch
new file mode 100644
index 000000000000..d821a0740606
--- /dev/null
+++ b/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch
@@ -0,0 +1,28 @@
+From 121061115d1902d8298fbe9ebc3f8d081a725934 Mon Sep 17 00:00:00 2001
+From: Tyler Gates <tgates81@gmail.com>
+Date: Mon, 20 Jul 2015 17:14:12 -0400
+Subject: [PATCH] daemon startup options as declared in conf.d/sssd
+
+---
+Gentoo bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=553678
+Upstrem bugzilla: https://fedorahosted.org/sssd/ticket/2722
+---
+ src/sysv/gentoo/sssd.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sysv/gentoo/sssd.in b/src/sysv/gentoo/sssd.in
+index 30d7559..7ced44f 100644
+--- a/src/sysv/gentoo/sssd.in
++++ b/src/sysv/gentoo/sssd.in
+@@ -7,7 +7,7 @@ depend(){
+
+ start(){
+ ebegin "Starting sssd"
+- start-stop-daemon --start --exec @sbindir@/sssd -- -Df
++ start-stop-daemon --start --exec @sbindir@/sssd -- -Df ${SSSD_OPTIONS}
+ eend ${?}
+ }
+
+--
+2.0.5
+
diff --git a/sys-auth/sssd/files/sssd-1.9.6-fix-init.patch b/sys-auth/sssd/files/sssd-1.9.6-fix-init.patch
new file mode 100644
index 000000000000..066a47efeb99
--- /dev/null
+++ b/sys-auth/sssd/files/sssd-1.9.6-fix-init.patch
@@ -0,0 +1,31 @@
+A couple of changes are necessary to make sssd work better on Gentoo Linux
+systems.
+
+- login manager can use sssd for login. Therefore it's necessary to adjust
+the dependencies of the script to use 'xdm' if it is available.
+- We need to send the debug output to files instead of stderr.
+
+Upstream:
+https://git.fedorahosted.org/cgit/sssd.git/commit/?id=c20dbd8f20e08676637ee7fc185ea7882a1f8651
+https://git.fedorahosted.org/cgit/sssd.git/commit/?id=9882475d3c59f4750a19953bb7d02edab198c900
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+
+Index: sssd-1.9.6/src/sysv/gentoo/sssd.in
+===================================================================
+--- sssd-1.9.6.orig/src/sysv/gentoo/sssd.in
++++ sssd-1.9.6/src/sysv/gentoo/sssd.in
+@@ -2,12 +2,12 @@
+
+ depend(){
+ need localmount netmount clock
+- use syslog
++ use syslog xdm
+ }
+
+ start(){
+ ebegin "Starting sssd"
+- start-stop-daemon --start --exec @sbindir@/sssd -- -D
++ start-stop-daemon --start --exec @sbindir@/sssd -- -Df
+ eend ${?}
+ }
+
diff --git a/sys-auth/sssd/files/sssd.conf b/sys-auth/sssd/files/sssd.conf
new file mode 100644
index 000000000000..33dab3ddcd5d
--- /dev/null
+++ b/sys-auth/sssd/files/sssd.conf
@@ -0,0 +1,4 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+SSSD_OPTIONS=""
diff --git a/sys-auth/sssd/files/sssd.service b/sys-auth/sssd/files/sssd.service
new file mode 100644
index 000000000000..1821089a6094
--- /dev/null
+++ b/sys-auth/sssd/files/sssd.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=System Security Services Daemon
+# SSSD will not be started until syslog is
+After=syslog.target
+
+[Service]
+ExecStart=/usr/sbin/sssd -D -f
+# These two should be used with traditional UNIX forking daemons
+# consult systemd.service(5) for more details
+Type=forking
+PIDFile=/run/sssd.pid
+
+[Install]
+WantedBy=multi-user.target
+