summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-10-02 14:34:37 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-10-02 15:19:46 -0400
commit3c85d38dda508f21a6158b60129f064c6c950a95 (patch)
tree89feecc3b9692dd2d5fe056bdedff5093828582c /sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
parentsys-devel/llvm: Backport X86 codegen bugfix for Chromium builds (diff)
downloadgentoo-3c85d38dda508f21a6158b60129f064c6c950a95.tar.gz
gentoo-3c85d38dda508f21a6158b60129f064c6c950a95.tar.bz2
gentoo-3c85d38dda508f21a6158b60129f064c6c950a95.zip
sys-auth/yubico-piv-tool: bump
Signed-off-by: Rick Farina <zerochaos@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild')
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
new file mode 100644
index 000000000000..5bbb1bafd01d
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-1.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Command line tool for the YubiKey PIV application"
+SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/openssl:0=[-bindist]
+ sys-apps/pcsc-lite
+"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "/PKG_CHECK_MODULES(\[CHECK/d" configure.ac || die
+ sed -i -e "s/@CHECK_CFLAGS@//" -e "s/@CHECK_LIBS@//" */*/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ rm "${D}"/usr/$(get_libdir)/*.la || die
+}