summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-14 12:24:14 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-14 12:41:11 -0700
commit04859ced85a4134caa2f9fcaaa9b82cbc958ddbb (patch)
tree5446d1858d1bd66e07ceb83cfe767366acc34997 /sys-auth
parentsys-apps/hwids: add support for python 3.8 and 3.9 (diff)
downloadgentoo-04859ced85a4134caa2f9fcaaa9b82cbc958ddbb.tar.gz
gentoo-04859ced85a4134caa2f9fcaaa9b82cbc958ddbb.tar.bz2
gentoo-04859ced85a4134caa2f9fcaaa9b82cbc958ddbb.zip
sys-auth/sssd: Add a mountain of missing deps
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/sssd/sssd-2.3.1.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/sys-auth/sssd/sssd-2.3.1.ebuild b/sys-auth/sssd/sssd-2.3.1.ebuild
index 52c5d6c314e1..a2692e592be6 100644
--- a/sys-auth/sssd/sssd-2.3.1.ebuild
+++ b/sys-auth/sssd/sssd-2.3.1.ebuild
@@ -12,7 +12,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test systemd"
+IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh systemd test valgrind"
RESTRICT="!test? ( test )"
COMMON_DEP="
@@ -56,12 +56,23 @@ RDEPEND="${COMMON_DEP}
>=sys-libs/glibc-2.17[nscd]
selinux? ( >=sec-policy/selinux-sssd-2.20120725-r9 )
"
+# FIXME: Add pam_wrapper when it enters the tree. Bug #730974
DEPEND="${COMMON_DEP}
- test? ( dev-libs/check )
+ test? (
+ app-crypt/p11-kit
+ dev-libs/check
+ dev-libs/softhsm:2
+ dev-util/cmocka
+ net-libs/gnutls[pkcs11,tools]
+ sys-libs/libfaketime
+ sys-libs/nss_wrapper
+ sys-libs/uid_wrapper
+ valgrind? ( dev-util/valgrind )
+ )
manpages? (
>=dev-libs/libxslt-1.1.26
app-text/docbook-xml-dtd:4.4
- )"
+ )"
CONFIG_CHECK="~KEYS"
@@ -125,6 +136,7 @@ multilib_src_configure() {
$(multilib_native_use_with sudo)
$(multilib_native_use_with autofs)
$(multilib_native_use_with ssh)
+ $(use_enable valgrind)
--with-crypto="libcrypto"
--without-python2-bindings
--without-python3-bindings