summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-16 22:37:50 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-16 22:42:10 +0200
commit3b593258c9174d021c6c9a186a01a9cbc8a898fe (patch)
tree5162bd5edb866ce7ba3fab387075510028227459 /sys-auth
parentapp-admin/entr: clean up old. (diff)
downloadgentoo-3b593258c9174d021c6c9a186a01a9cbc8a898fe.tar.gz
gentoo-3b593258c9174d021c6c9a186a01a9cbc8a898fe.tar.bz2
gentoo-3b593258c9174d021c6c9a186a01a9cbc8a898fe.zip
sys-auth/solo-python: new package
Command-line tool and Python library for interfacing with SoloKey FIDO2 security keys. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/solo-python/Manifest1
-rw-r--r--sys-auth/solo-python/metadata.xml17
-rw-r--r--sys-auth/solo-python/solo-python-0.0.26.ebuild34
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
new file mode 100644
index 000000000000..8bbc1177b9e0
--- /dev/null
+++ b/sys-auth/solo-python/Manifest
@@ -0,0 +1 @@
+DIST solo-python-0.0.26.tar.gz 35251 BLAKE2B 76e515667220a8efdd16e159008eed8232721e0a8a1a1bffbc773cfa832b2f112d8dc229bf69dc4ccbee1d11b41d630a2d91e2383ebd19158d8c46ccf4f355de SHA512 f97da4a4ed3b0e0f4715407b179d8a8c1385076611fe8669cec6b514313d38dd14c6c22434b73e2c72f7456407a6c942b26b72cca7a56969cfbc630ee25aad85
diff --git a/sys-auth/solo-python/metadata.xml b/sys-auth/solo-python/metadata.xml
new file mode 100644
index 000000000000..9014b8d50308
--- /dev/null
+++ b/sys-auth/solo-python/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The command-line tool 'solo' provided by this package can be used to reset a SoloKey,
+ set/change the PIN, generate credentials, interact with the on-board TRNG, update
+ the firmware, and more. See the output of 'solo key --help' for more information.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">solokeys/solo-python</remote-id>
+ <remote-id type="pypi">solo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/solo-python/solo-python-0.0.26.ebuild b/sys-auth/solo-python/solo-python-0.0.26.ebuild
new file mode 100644
index 000000000000..a63f71dd2241
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.26.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}