summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2022-12-27 22:22:13 +0100
committerSam James <sam@gentoo.org>2022-12-28 00:53:28 +0000
commit4e4783cc76ad8f0d81c30c1c5e9483ffc5776f7e (patch)
tree474857f85cfd29587672092c976d4dea2bdc8a83 /sys-auth
parentsys-auth/libfprint: add 1.94.5 (diff)
downloadgentoo-4e4783cc76ad8f0d81c30c1c5e9483ffc5776f7e.tar.gz
gentoo-4e4783cc76ad8f0d81c30c1c5e9483ffc5776f7e.tar.bz2
gentoo-4e4783cc76ad8f0d81c30c1c5e9483ffc5776f7e.zip
sys-auth/fprintd: add 1.94.2
Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/28865 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/fprintd/Manifest1
-rw-r--r--sys-auth/fprintd/fprintd-1.94.2.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-auth/fprintd/Manifest b/sys-auth/fprintd/Manifest
index 9159f3036b33..be1f143b213a 100644
--- a/sys-auth/fprintd/Manifest
+++ b/sys-auth/fprintd/Manifest
@@ -1 +1,2 @@
DIST fprintd-v1.94.1.tar.bz2 658149 BLAKE2B 734da268e308b08b04cbc661d889f52c4e8b2dd61d7a67961eaba5a6aa130f6972525820a17e8b6dd53d38508629139a5a0be20b69eaea45430cc60da5cd9a27 SHA512 ff22087e09ab9f75e458e71f595d611ea97240596a25bd96f41a0fb1de865336f8c2edbd49d5e7c8132a7e554d8311337ec02991dde358cba1962d4cb182447d
+DIST fprintd-v1.94.2.tar.bz2 657989 BLAKE2B 5855ab453ae6d73e08c60c699a95609262fd121ab020f9ffeafb8d1891a60f761f47e4acd11554179b6d9cbed8a734aafb012a4b6de3e9ad67d4160534a0e6c6 SHA512 0b5ebc595b617fbe9167c41a80e31ae74e7bdc87350b0420839e1a6229d7709e51ff2836858c46d8d30549a1f0811b0f697034fcdd09512b5c1099f0f0a3b112
diff --git a/sys-auth/fprintd/fprintd-1.94.2.ebuild b/sys-auth/fprintd/fprintd-1.94.2.ebuild
new file mode 100644
index 000000000000..65065793fd36
--- /dev/null
+++ b/sys-auth/fprintd/fprintd-1.94.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson pam python-any-r1 systemd
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="D-Bus service to access fingerprint readers"
+HOMEPAGE="https://gitlab.freedesktop.org/libfprint/fprintd"
+SRC_URI="https://gitlab.freedesktop.org/libfprint/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc pam systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ >=sys-auth/libfprint-1.94.0:2
+ sys-auth/polkit
+ pam? (
+ sys-libs/pam
+ systemd? ( sys-apps/systemd:= )
+ !systemd? ( sys-auth/elogind:= )
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ pam? ( sys-libs/pam_wrapper[${PYTHON_USEDEP}] )
+ ')
+ )
+"
+
+BDEPEND="
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-util/gtk-doc
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.90.7_0001-add-test-feature-and-make-tests-optional.patch"
+ "${FILESDIR}/${PN}-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+python_check_deps() {
+ if use test; then
+ has_version -d "sys-libs/pam_wrapper[${PYTHON_USEDEP}]"
+ fi
+
+ has_version -d "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ has_version -d "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
+ has_version -d "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test)
+ $(meson_use pam)
+ -Dgtk_doc=$(usex doc true false)
+ -Dman=true
+ -Dsystemd_system_unit_dir=$(systemd_get_systemunitdir)
+ -Dpam_modules_dir=$(getpam_mod_dir)
+ -Dlibsystemd=$(usex systemd libsystemd libelogind)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ dodoc AUTHORS NEWS README TODO
+ newdoc pam/README README.pam_fprintd
+}
+
+pkg_postinst() {
+ elog "Please take a look at README.pam_fprintd for integration docs."
+}