summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-12-13 00:56:33 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-12-13 00:56:33 +0300
commit77bfe9db0acb867e2e07094c0dc7b650c8bd4fe4 (patch)
tree86430ad1d9ad3b2f3846e50dcf06ad1e184b49ce /sys-auth
parentapp-doc/doxygen: require at least clang-10 (diff)
downloadgentoo-77bfe9db0acb867e2e07094c0dc7b650c8bd4fe4.tar.gz
gentoo-77bfe9db0acb867e2e07094c0dc7b650c8bd4fe4.tar.bz2
gentoo-77bfe9db0acb867e2e07094c0dc7b650c8bd4fe4.zip
sys-auth/pam_smb: port to EAPI=7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_smb/files/10-pam_smb-bash-3.1.patch4
-rw-r--r--sys-auth/pam_smb/pam_smb-2.0.0_rc6-r2.ebuild14
2 files changed, 11 insertions, 7 deletions
diff --git a/sys-auth/pam_smb/files/10-pam_smb-bash-3.1.patch b/sys-auth/pam_smb/files/10-pam_smb-bash-3.1.patch
index 570655d82462..df8050442d6b 100644
--- a/sys-auth/pam_smb/files/10-pam_smb-bash-3.1.patch
+++ b/sys-auth/pam_smb/files/10-pam_smb-bash-3.1.patch
@@ -1,6 +1,6 @@
diff -Nurp pam_smb-2.0.0_rc6.orig/configure pam_smb-2.0.0_rc6/configure
---- configure 2006-03-17 15:02:01.000000000 +0000
-+++ configure 2006-03-17 15:02:01.000000000 +0000
+--- a/configure 2006-03-17 15:02:01.000000000 +0000
++++ b/configure 2006-03-17 15:02:01.000000000 +0000
@@ -1486,7 +1486,7 @@ else
# results, and the version is kept in special file).
diff --git a/sys-auth/pam_smb/pam_smb-2.0.0_rc6-r2.ebuild b/sys-auth/pam_smb/pam_smb-2.0.0_rc6-r2.ebuild
index 16b55f2637ef..d10331b793c5 100644
--- a/sys-auth/pam_smb/pam_smb-2.0.0_rc6-r2.ebuild
+++ b/sys-auth/pam_smb/pam_smb-2.0.0_rc6-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils pam
+inherit pam toolchain-funcs
MY_P=${P/_rc/-rc}
@@ -16,7 +16,6 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
-IUSE=""
DEPEND=">=sys-libs/pam-0.75"
RDEPEND="${DEPEND}"
@@ -24,13 +23,18 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}/10-pam_smb-bash-3.1.patch"
+ default
+ eapply "${FILESDIR}/10-pam_smb-bash-3.1.patch"
}
src_configure() {
econf --disable-root-only
}
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
dopammod pamsmbm/pam_smb_auth.so
dosbin pamsmbd/pamsmbd