summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:52:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:52:54 +0200
commit8c0489ea881b62d1b0075838e19c0ee82df8f0ca (patch)
treef02e3a7dfcbfa2d46b94856f778977e3dce0630c /sys-auth
parentmedia-plugins/qmmp-plugin-pack: Bump to version 1.2.1 (diff)
downloadgentoo-8c0489ea881b62d1b0075838e19c0ee82df8f0ca.tar.gz
gentoo-8c0489ea881b62d1b0075838e19c0ee82df8f0ca.tar.bz2
gentoo-8c0489ea881b62d1b0075838e19c0ee82df8f0ca.zip
sys-auth/pam_yubico: Security bump to version 2.26 (CVE-2018-9275)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_yubico/Manifest1
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.26.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/Manifest b/sys-auth/pam_yubico/Manifest
index b704e84fb400..80f90b51957b 100644
--- a/sys-auth/pam_yubico/Manifest
+++ b/sys-auth/pam_yubico/Manifest
@@ -1,2 +1,3 @@
DIST pam_yubico-2.24.tar.gz 418419 BLAKE2B 5ae988a3ba3244761d1fcadfc25f67a6c8cefd78d24535f4644ca469a5a1fb274832fb17e76d18376645960f532bf1107e6eb08112b4eacf1c797faf0349b5ca SHA512 3554b40d97ede9d02102a0661e732347a0ab2cb012fa4330cc8227289a03398a7b974ee9d170604dce53ebef1bedade5c7ab9d5657560b0ba8e4c65432c1112c
DIST pam_yubico-2.25.tar.gz 422192 BLAKE2B 54f27f9a0ff64c529c74415cf4530cdd1c359325beeda4d8ce2b51af4f9b53c69284696de21a5c1e3b4eed5102571e320cf068693fbd43d144ad2c9f40c39b72 SHA512 c561bedd35d3a84cc2129f12e358b77ac425520acf13444c2918cb17c9c4158d29dc5049b2e03dd30a1f04e8568980d80af13a6a0cfd9cc8e70eee8738727d70
+DIST pam_yubico-2.26.tar.gz 423451 BLAKE2B be65b9726d3b5d353577014c78163d9e092d3d98baf9c22c2a43bbbb5362589c18713712d218fd154cf493211cefd2924158b326db45c2b7dd0aee9aa9080de5 SHA512 4adba37f07e1fe1a2c4b534246ef0e862be76e3b1ce0ed6f11f15436f537cd5963f00abf48f6faa7e65b025ff6924dbaf918db1675b1e2cb89a802d2f2d6a4ec
diff --git a/sys-auth/pam_yubico/pam_yubico-2.26.ebuild b/sys-auth/pam_yubico/pam_yubico-2.26.ebuild
new file mode 100644
index 000000000000..034bfdfc4539
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+
+RDEPEND="
+ virtual/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ local myeconfargs=(
+ --with-cr
+ --with-pam-dir=/$(get_libdir)/security
+ $(use_with ldap)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ find "${D}" -name '*.la' -delete || die
+}