summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-09-04 17:04:46 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-09-04 17:07:45 -0700
commit8f75b8e5458a93664ab8993bc95e769aae0e0b7f (patch)
treec7e701125eea799ab2cb9e241d1743e769c6cb4f /sys-auth
parentRevert "dev-python/python-daemon-2.2.4: Remove pypy3 due to missing twine" (diff)
downloadgentoo-8f75b8e5458a93664ab8993bc95e769aae0e0b7f.tar.gz
gentoo-8f75b8e5458a93664ab8993bc95e769aae0e0b7f.tar.bz2
gentoo-8f75b8e5458a93664ab8993bc95e769aae0e0b7f.zip
sys-auth/nss-pam-ldapd-0.9.11-r3: EAPI=7, py38 (bug #718520)
Closes: https://bugs.gentoo.org/718520 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Patrick McLean <patrick.mclean@sony.com> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-relative-imports.patch452
-rw-r--r--sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-tests.patch34
-rw-r--r--sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-use-mkstemp.patch25
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11-r3.ebuild167
4 files changed, 678 insertions, 0 deletions
diff --git a/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-relative-imports.patch b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-relative-imports.patch
new file mode 100644
index 000000000000..101d0c774505
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-relative-imports.patch
@@ -0,0 +1,452 @@
+diff --git a/pynslcd/Makefile.am b/pynslcd/Makefile.am
+index 383dd3c..39a3bfb 100644
+--- a/pynslcd/Makefile.am
++++ b/pynslcd/Makefile.am
+@@ -19,7 +19,7 @@
+
+ pynslcddir = $(datadir)/pynslcd
+
+-pynslcd_PYTHON = pynslcd.py attmap.py cache.py cfg.py common.py expr.py \
++pynslcd_PYTHON = main.py attmap.py cache.py cfg.py common.py expr.py \
+ mypidfile.py invalidator.py search.py tio.py \
+ config.py alias.py ether.py group.py host.py netgroup.py \
+ network.py passwd.py protocol.py rpc.py service.py \
+@@ -38,6 +38,6 @@ constants.py: constants.py.in $(top_srcdir)/nslcd.h
+ # create a symbolic link for the pynslcd daemon and fix permissions
+ install-data-hook:
+ $(MKDIR_P) $(DESTDIR)$(sbindir)
+- [ -L $(DESTDIR)$(sbindir)/pynslcd ] || $(LN_S) $(pynslcddir)/pynslcd.py $(DESTDIR)$(sbindir)/pynslcd
+- chmod a+rx $(DESTDIR)$(pynslcddir)/pynslcd.py
+- sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(pynslcddir)/pynslcd.py
++ [ -L $(DESTDIR)$(sbindir)/pynslcd ] || $(LN_S) $(pynslcddir)/main.py $(DESTDIR)$(sbindir)/pynslcd
++ chmod a+rx $(DESTDIR)$(pynslcddir)/main.py
++ sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(pynslcddir)/main.py
+diff --git a/pynslcd/alias.py b/pynslcd/alias.py
+index 8096309..614dd53 100644
+--- a/pynslcd/alias.py
++++ b/pynslcd/alias.py
+@@ -18,10 +18,10 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/attmap.py b/pynslcd/attmap.py
+index 61862df..4d450f6 100644
+--- a/pynslcd/attmap.py
++++ b/pynslcd/attmap.py
+@@ -45,7 +45,7 @@ import re
+ import ldap.dn
+ from ldap.filter import escape_filter_chars
+
+-from expr import Expression
++from pynslcd.expr import Expression
+
+
+ # exported names
+diff --git a/pynslcd/cfg.py b/pynslcd/cfg.py
+index 877d442..14ae850 100644
+--- a/pynslcd/cfg.py
++++ b/pynslcd/cfg.py
+@@ -133,8 +133,8 @@ _tls_reqcert_options = {'never': ldap.OPT_X_TLS_NEVER,
+
+ def _get_maps():
+ # separate function as not to pollute the namespace and avoid import loops
+- import alias, ether, group, host, netgroup, network, passwd # noqa: E401
+- import protocol, rpc, service, shadow # noqa: E401
++ from pynslcd import alias, ether, group, host, netgroup, network, passwd # noqa: E401
++ from pynslcd import protocol, rpc, service, shadow # noqa: E401
+ import sys
+ return dict(
+ alias=alias, aliases=alias,
+@@ -293,7 +293,7 @@ def read(filename): # noqa: C901 (many simple branches)
+ # pam_authz_search <FILTER>
+ m = re.match(r'pam_authz_search\s+(?P<value>\S.*)', line, re.IGNORECASE)
+ if m:
+- from expr import Expression
++ from pynslcd.expr import Expression
+ pam_authz_searches.append(Expression(m.group('value')))
+ # TODO: check pam_authz_search expression to only contain
+ # username, service, ruser, rhost, tty, hostname, fqdn, dn or
+diff --git a/pynslcd/common.py b/pynslcd/common.py
+index a5b168d..568ac2f 100644
+--- a/pynslcd/common.py
++++ b/pynslcd/common.py
+@@ -23,9 +23,9 @@ import sys
+
+ import ldap
+
+-from attmap import Attributes # noqa: F401 (used by other modules)
+-import cfg
+-import constants
++from pynslcd.attmap import Attributes # noqa: F401 (used by other modules)
++from pynslcd import cfg
++from pynslcd import constants
+
+
+ def is_valid_name(name):
+diff --git a/pynslcd/config.py b/pynslcd/config.py
+index ee57db3..ba8badb 100644
+--- a/pynslcd/config.py
++++ b/pynslcd/config.py
+@@ -18,9 +18,9 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cfg
+-import common
+-import constants
++from pynslcd import cfg
++from pynslcd import common
++from pynslcd import constants
+
+
+ class ConfigGetRequest(common.Request):
+diff --git a/pynslcd/ether.py b/pynslcd/ether.py
+index 9462ef0..2edc5de 100644
+--- a/pynslcd/ether.py
++++ b/pynslcd/ether.py
+@@ -20,10 +20,10 @@
+
+ import struct
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ def ether_aton(ether):
+diff --git a/pynslcd/group.py b/pynslcd/group.py
+index 263e40c..422ee9e 100644
+--- a/pynslcd/group.py
++++ b/pynslcd/group.py
+@@ -23,12 +23,12 @@ import logging
+ import ldap
+ from ldap.filter import escape_filter_chars
+
+-import cache
+-import cfg
+-import common
+-import constants
+-import passwd
+-import search
++from pynslcd import cache
++from pynslcd import cfg
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import passwd
++from pynslcd import search
+
+
+ def clean(lst):
+diff --git a/pynslcd/host.py b/pynslcd/host.py
+index c6639df..30259d6 100644
+--- a/pynslcd/host.py
++++ b/pynslcd/host.py
+@@ -18,10 +18,10 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/invalidator.py b/pynslcd/invalidator.py
+index 6d2eefe..b54946e 100644
+--- a/pynslcd/invalidator.py
++++ b/pynslcd/invalidator.py
+@@ -23,7 +23,7 @@ import logging
+ import os
+ import subprocess
+
+-import cfg
++from pynslcd import cfg
+
+
+ # the file descriptor used for sending messages to the child process
+diff --git a/pynslcd/mypidfile.py b/pynslcd/mypidfile.py
+index 42935e2..dd7d59a 100644
+--- a/pynslcd/mypidfile.py
++++ b/pynslcd/mypidfile.py
+@@ -22,7 +22,7 @@ import errno
+ import fcntl
+ import os
+
+-import cfg
++from pynslcd import cfg
+
+
+ class MyPIDLockFile(object):
+diff --git a/pynslcd/netgroup.py b/pynslcd/netgroup.py
+index 47a4c6e..8d0fbb2 100644
+--- a/pynslcd/netgroup.py
++++ b/pynslcd/netgroup.py
+@@ -20,10 +20,10 @@
+
+ import re
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ _netgroup_triple_re = re.compile(
+diff --git a/pynslcd/network.py b/pynslcd/network.py
+index da587b9..3b94d06 100644
+--- a/pynslcd/network.py
++++ b/pynslcd/network.py
+@@ -18,10 +18,10 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/pam.py b/pynslcd/pam.py
+index b372cdd..bb7add8 100644
+--- a/pynslcd/pam.py
++++ b/pynslcd/pam.py
+@@ -27,12 +27,12 @@ import ldap
+ from ldap.controls.ppolicy import PasswordPolicyControl, PasswordPolicyError
+ from ldap.filter import escape_filter_chars
+
+-import cfg
+-import common
+-import constants
+-import passwd
+-import search
+-import shadow
++from pynslcd import cfg
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import passwd
++from pynslcd import search
++from pynslcd import shadow
+
+
+ random = random.SystemRandom()
+diff --git a/pynslcd/passwd.py b/pynslcd/passwd.py
+index 1274f21..51ae57e 100644
+--- a/pynslcd/passwd.py
++++ b/pynslcd/passwd.py
+@@ -20,11 +20,11 @@
+
+ import logging
+
+-import cache
+-import cfg
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import cfg
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/protocol.py b/pynslcd/protocol.py
+index dc41c4b..396f337 100644
+--- a/pynslcd/protocol.py
++++ b/pynslcd/protocol.py
+@@ -18,10 +18,10 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/pynslcd.py b/pynslcd/pynslcd.py
+index 0691b61..973ecd9 100755
+--- a/pynslcd/pynslcd.py
++++ b/pynslcd/pynslcd.py
+@@ -30,13 +30,13 @@ import threading
+ import daemon
+ import ldap
+
+-import cfg
+-import common
+-import constants
+-import invalidator
+-import mypidfile
+-import search
+-from tio import TIOStream
++import pynslcd.cfg as cfg
++import pynslcd.common as common
++import pynslcd.constants as constants
++import pynslcd.invalidator as invalidator
++import pynslcd.mypidfile as mypidfile
++import pynslcd.search as search
++from pynslcd.tio import TIOStream
+
+
+ # the name of the program
+@@ -188,20 +188,20 @@ def getpeercred(fd):
+
+
+ handlers = {}
+-handlers.update(common.get_handlers('config'))
+-handlers.update(common.get_handlers('alias'))
+-handlers.update(common.get_handlers('ether'))
+-handlers.update(common.get_handlers('group'))
+-handlers.update(common.get_handlers('host'))
+-handlers.update(common.get_handlers('netgroup'))
+-handlers.update(common.get_handlers('network'))
+-handlers.update(common.get_handlers('passwd'))
+-handlers.update(common.get_handlers('protocol'))
+-handlers.update(common.get_handlers('rpc'))
+-handlers.update(common.get_handlers('service'))
+-handlers.update(common.get_handlers('shadow'))
+-handlers.update(common.get_handlers('pam'))
+-handlers.update(common.get_handlers('usermod'))
++handlers.update(common.get_handlers('pynslcd.config'))
++handlers.update(common.get_handlers('pynslcd.alias'))
++handlers.update(common.get_handlers('pynslcd.ether'))
++handlers.update(common.get_handlers('pynslcd.group'))
++handlers.update(common.get_handlers('pynslcd.host'))
++handlers.update(common.get_handlers('pynslcd.netgroup'))
++handlers.update(common.get_handlers('pynslcd.network'))
++handlers.update(common.get_handlers('pynslcd.passwd'))
++handlers.update(common.get_handlers('pynslcd.protocol'))
++handlers.update(common.get_handlers('pynslcd.rpc'))
++handlers.update(common.get_handlers('pynslcd.service'))
++handlers.update(common.get_handlers('pynslcd.shadow'))
++handlers.update(common.get_handlers('pynslcd.pam'))
++handlers.update(common.get_handlers('pynslcd.usermod'))
+
+
+ def acceptconnection(nslcd_serversocket, session):
+diff --git a/pynslcd/rpc.py b/pynslcd/rpc.py
+index 49d9c7c..e1ea4f5 100644
+--- a/pynslcd/rpc.py
++++ b/pynslcd/rpc.py
+@@ -18,10 +18,10 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ # 02110-1301 USA
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/search.py b/pynslcd/search.py
+index 39850d2..f017451 100644
+--- a/pynslcd/search.py
++++ b/pynslcd/search.py
+@@ -24,7 +24,7 @@ import sys
+ import ldap
+ import ldap.ldapobject
+
+-import cfg
++from pynslcd import cfg
+
+
+ # global indicator that there was some error connection to an LDAP server
+diff --git a/pynslcd/service.py b/pynslcd/service.py
+index b0c53e3..96c2aaf 100644
+--- a/pynslcd/service.py
++++ b/pynslcd/service.py
+@@ -20,10 +20,10 @@
+
+ import datetime
+
+-import cache
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/shadow.py b/pynslcd/shadow.py
+index 59e1af6..3ed695b 100644
+--- a/pynslcd/shadow.py
++++ b/pynslcd/shadow.py
+@@ -20,11 +20,11 @@
+
+ import logging
+
+-import cache
+-import cfg
+-import common
+-import constants
+-import search
++from pynslcd import cache
++from pynslcd import cfg
++from pynslcd import common
++from pynslcd import constants
++from pynslcd import search
+
+
+ attmap = common.Attributes(
+diff --git a/pynslcd/usermod.py b/pynslcd/usermod.py
+index 4e37ded..ffd651b 100644
+--- a/pynslcd/usermod.py
++++ b/pynslcd/usermod.py
+@@ -26,10 +26,10 @@ import os.path
+
+ import ldap
+
+-import cfg
+-import constants
+-import pam
+-import passwd
++from pynslcd import cfg
++from pynslcd import constants
++from pynslcd import pam
++from pynslcd import passwd
+
+
+ def list_shells():
diff --git a/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-tests.patch b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-tests.patch
new file mode 100644
index 000000000000..5e13854b6cd1
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-tests.patch
@@ -0,0 +1,34 @@
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 1bbbcc2..4adf062 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -23,7 +23,7 @@ TESTS = test_dict test_set test_tio test_expr test_getpeercred test_cfg \
+ test_pamcmds.sh test_manpages.sh test_clock \
+ test_tio_timeout
+ if HAVE_PYTHON
+- TESTS += test_pycompile.sh test_pylint.sh
++ TESTS += test_pycompile.sh
+ endif
+ if ENABLE_PYNSLCD
+ TESTS += test_pynslcd_cache.py test_doctest.sh
+@@ -48,7 +48,6 @@ EXTRA_DIST = README nslcd-test.conf usernames.txt testenv.sh test_myldap.sh \
+ test_nsscmds.sh test_ldapcmds.sh test_pamcmds.sh \
+ test_pamcmds.expect test_manpages.sh \
+ test_pycompile.sh test_doctest.sh \
+- test_pylint.sh pylint.rc \
+ test_flake8.sh flake8.ini \
+ test_pynslcd_cache.py \
+ setup_slapd.sh config.ldif test.ldif
+diff --git a/tests/test_doctest.sh b/tests/test_doctest.sh
+index 5b3a13d..26c73e7 100755
+--- a/tests/test_doctest.sh
++++ b/tests/test_doctest.sh
+@@ -38,7 +38,7 @@ find_python() {
+ fi
+ done
+ }
+-interpreters=`find_python | sort -u`
++interpreters=${PYTHON}
+
+ # if Python is missing, ignore
+ if [ -z "$interpreters" ]
diff --git a/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-use-mkstemp.patch b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-use-mkstemp.patch
new file mode 100644
index 000000000000..1803067f402b
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nss-pam-ldapd-0.9.11-use-mkstemp.patch
@@ -0,0 +1,25 @@
+diff --git a/pynslcd/cache.py b/pynslcd/cache.py
+index 0be3a71..b463d2e 100644
+--- a/pynslcd/cache.py
++++ b/pynslcd/cache.py
+@@ -22,6 +22,7 @@ import datetime
+ import os
+ import sqlite3
+ import sys
++import tempfile
+
+
+ # TODO: probably create a config table
+@@ -192,10 +193,8 @@ _connection = None
+ def _get_connection():
+ global _connection
+ if _connection is None:
+- filename = '/tmp/pynslcd_cache.sqlite'
+- dirname = os.path.dirname(filename)
+- if not os.path.isdir(dirname):
+- os.mkdir(dirname)
++ tmpfd, filename = tempfile.mkstemp(suffix=".sqlite", prefix="pynslcd_cache")
++ os.close(tmpfd)
+ connection = sqlite3.connect(
+ filename, detect_types=sqlite3.PARSE_DECLTYPES,
+ check_same_thread=False)
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11-r3.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11-r3.ebuild
new file mode 100644
index 000000000000..bc76968a7184
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.11-r3.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+inherit eutils prefix python-r1 autotools multilib multilib-minimal systemd s6
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="https://arthurdejong.org/nss-pam-ldapd/"
+SRC_URI="https://arthurdejong.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos +pam pynslcd sasl test +utils"
+RESTRICT="!test? ( test )"
+
+COMMON_DEP="
+ acct-group/nslcd
+ acct-user/nslcd
+ net-nds/openldap[${MULTILIB_USEDEP}]
+ sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ sys-libs/pam[${MULTILIB_USEDEP}]
+ utils? ( ${PYTHON_DEPS} )
+ pynslcd? (
+ dev-python/python-ldap[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
+ )
+ !sys-auth/nss_ldap
+ !sys-auth/pam_ldap
+"
+RDEPEND="${COMMON_DEP}"
+DEPEND="${COMMON_DEP}
+ test? (
+ ${PYTHON_DEPS}
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/automake
+"
+
+REQUIRED_USE="
+ utils? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} pynslcd )
+"
+
+PATCHES=(
+ "${FILESDIR}/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch"
+ "${FILESDIR}/nss-pam-ldapd-0.9.11-use-mkstemp.patch"
+ "${FILESDIR}/nss-pam-ldapd-0.9.11-relative-imports.patch"
+ "${FILESDIR}/nss-pam-ldapd-0.9.11-tests.patch"
+)
+
+src_prepare() {
+ default
+ use utils && python_setup
+ touch pynslcd/__init__.py || die "Could not create __init__.py for pynslcd"
+ mv pynslcd/pynslcd.py pynslcd/main.py || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local -a myconf=(
+ --disable-utils
+ --enable-warnings
+ --with-ldap-lib=openldap
+ --with-ldap-conf-file=/etc/nslcd.conf
+ --with-nslcd-pidfile=/run/nslcd/nslcd.pid
+ --with-nslcd-socket=/run/nslcd/socket
+ $(usex x86-fbsd '--with-nss-flavour=' '--with-nss-flavour=' 'freebsd' 'glibc')
+ $(use_enable pynslcd)
+ $(use_enable debug)
+ $(use_enable kerberos)
+ $(use_enable pam)
+ $(use_enable sasl)
+ )
+
+ # nss libraries always go in /lib on Gentoo
+ if multilib_is_native_abi ; then
+ myconf+=("--with-pam-seclib-dir=${EPREFIX}/$(get_libdir)/security")
+ myconf+=("--libdir=${EPREFIX}/$(get_libdir)")
+ else
+ myconf+=("--with-pam-seclib-dir=/$(get_libdir)/security")
+ myconf+=("--libdir=/$(get_libdir)")
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ ln -s ../pynslcd/constants.py utils/constants.py || die
+ python_foreach_impl python_test
+ popd >/dev/null || die
+}
+
+python_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ local script
+
+ newinitd "${FILESDIR}"/nslcd.init nslcd
+ s6_install_service nslcd "${FILESDIR}"/nslcd.s6
+
+ insinto /usr/share/nss-pam-ldapd
+ doins "${WORKDIR}/${P}/nslcd.conf"
+
+ fperms o-r /etc/nslcd.conf
+
+ if use utils; then
+ python_moduleinto nslcd
+ python_foreach_impl python_domodule utils/*.py
+
+ for script in chsh getent; do
+ python_foreach_impl python_newscript utils/${script}.py ${script}.ldap
+ done
+ fi
+ if use pynslcd; then
+ rm -rf "${D}"/usr/share/pynslcd
+ python_moduleinto pynslcd
+ python_foreach_impl python_domodule pynslcd/*.py
+ python_scriptinto /usr/sbin
+ python_foreach_impl python_newscript pynslcd/main.py pynslcd
+ newinitd "${FILESDIR}"/pynslcd.init pynslcd
+ fi
+
+ systemd_newtmpfilesd "${FILESDIR}"/nslcd-tmpfiles.conf nslcd.conf
+ systemd_newunit "${FILESDIR}"/nslcd.service nslcd.service
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use pynslcd; then
+ python_moduleinto pynslcd
+ python_foreach_impl python_domodule pynslcd/*.py
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "For this to work you must configure /etc/nslcd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ echo
+ elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ echo
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
+ elog
+ elog "If you have >=sys-apps/openrc-0.16.3, you can also use s6"
+ elog "to supervise this service."
+ elog "To do this, emerge sys-apps/s6 then add nslcd-s6"
+ elog "default runlevel instead of nslcd."
+ elog
+ elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf"
+ elog " is now named /etc/nslcd.conf"
+ echo
+}