summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-21 13:59:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-21 13:59:21 +0300
commitbcf5fc2eedd0a8eca6f440a58bee30892c309cdd (patch)
treee4ebbf5928bca80ef5631ac15a02e03cf4d18c3b /sys-auth
parentdev-tex/latex-beamer: Stabilize 3.70 ALLARCHES, #910629 (diff)
downloadgentoo-bcf5fc2eedd0a8eca6f440a58bee30892c309cdd.tar.gz
gentoo-bcf5fc2eedd0a8eca6f440a58bee30892c309cdd.tar.bz2
gentoo-bcf5fc2eedd0a8eca6f440a58bee30892c309cdd.zip
sys-auth/seatd: add 0.8.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/seatd-0.8.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index cbad969e380b..273b094f6b87 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1 +1,2 @@
DIST seatd-0.7.0.tar.gz 39198 BLAKE2B eddae25b353a5ff4da8aa8b41ead6e6ebab6ffa321376887769cbaf22c3c1b8448d84758749714b82d6ca2d602f2140042634bbeb9312449d8ac207b3774851e SHA512 c81c43994b92672a388bf255edb1fe24d3dba7ece2eb35f9fedc05cc0b8e464e9167ffed037645c4072430fe7b3b8fc80cc99f21fb5100654b5dd23a94742e66
+DIST seatd-0.8.0.tar.gz 39349 BLAKE2B 920270808f28c85badb173af22edb03960f2b9cdce5af3124c64fe68c52a77f002272d2f19e97d107303c55ad6de498d279f6b05311793270c6ee84565fc435e SHA512 93b1e5c170564ce9654e4df9985af95cb505274b36e950998bb1f16803d2d46712140eded2bdd8d5e85aec62070afd9c224184276d79a0ff0813408dfc472db7
diff --git a/sys-auth/seatd/seatd-0.8.0.ebuild b/sys-auth/seatd/seatd-0.8.0.ebuild
new file mode 100644
index 000000000000..a9bfcfa000ff
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}
+ server? ( acct-group/seat )
+"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd-r1" seatd
+ systemd_dounit contrib/systemd/seatd.service
+
+ if has_version '<sys-auth/seatd-0.7.0-r2'; then
+ elog "For OpenRC users: seatd is now using the 'seat' group instead of the 'video' group"
+ elog "Make sure your user(s) are in the 'seat' group."
+ elog "Note: 'video' is still needed for GPU access like OpenGL"
+ fi
+ fi
+}