summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-15 11:16:14 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-15 11:20:07 +0000
commitdb1d00b78915f0257732b2eb50e603e440febbdb (patch)
tree625292196879799aafd913066e16c6eeac558523 /sys-auth
parentapp-backup/borgmatic: add 1.5.24 (diff)
downloadgentoo-db1d00b78915f0257732b2eb50e603e440febbdb.tar.gz
gentoo-db1d00b78915f0257732b2eb50e603e440febbdb.tar.bz2
gentoo-db1d00b78915f0257732b2eb50e603e440febbdb.zip
sys-auth/solo-python: add 0.1.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/solo-python/Manifest1
-rw-r--r--sys-auth/solo-python/solo-python-0.1.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index bd8819b2c9de..424da7c81c8c 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1 +1,2 @@
DIST solo-python-0.0.31.tar.gz 34959 BLAKE2B abc7bb014bb6eedcd0178cb600c626ca6e2b4773083916db698c0dd9639208206da010470f77813074137667afb5c6725311c3406762a8ab5a029e9966b227d6 SHA512 e8c81524b6d10bc38898b19e35ab2f7b95bea7906553de9e0598fc160b5b9b61f4f8b40e2238631738e1b69ef52652af1b3e84aa0a3552126929c4512210c1fa
+DIST solo1-0.1.1.tar.gz 39300 BLAKE2B 3d486d7d515acf03131ef640e38f804f10b4601db37d2b668ea50a715e5b0b38e95d16f3dec41a282bfaacf743a531ef6b56f9b688bdbb7d7f8acc56bdd1d77c SHA512 7e345059205f8753d7d89a22091316f5a529e5afedd82f7a03acbe494035479ef28731cc2b91e8d46058ce638a0e420db8c5f57fcedfcc39b6d07de5eda86f93
diff --git a/sys-auth/solo-python/solo-python-0.1.1.ebuild b/sys-auth/solo-python/solo-python-0.1.1.ebuild
new file mode 100644
index 000000000000..85214dcdd146
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+MY_PN="solo1"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CLI and Python library for SoloKeys Solo 1"
+HOMEPAGE="https://github.com/solokeys/solo1-cli"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt 0.1.1; then
+ ewarn "Note that since version 0.1.1 the CLI executable is called '${MY_PN}' rather than 'solo'"
+ ewarn "The old name can still be used for now but is deprecated"
+ break
+ fi
+ done
+ fi
+}