summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:12 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:12 +0100
commitf4af38b859561b460b9ab17166880b06339c5966 (patch)
tree2910c1f08eab87e79e323eb5e0b78b24b05e13db /sys-auth
parentsys-auth/pam_fprint: Port to EAPI 6 (diff)
downloadgentoo-f4af38b859561b460b9ab17166880b06339c5966.tar.gz
gentoo-f4af38b859561b460b9ab17166880b06339c5966.tar.bz2
gentoo-f4af38b859561b460b9ab17166880b06339c5966.zip
sys-auth/realtime-base: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/realtime-base/realtime-base-0.1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/sys-auth/realtime-base/realtime-base-0.1.ebuild b/sys-auth/realtime-base/realtime-base-0.1.ebuild
index 7af8533be7c8..1fc02cd38e08 100644
--- a/sys-auth/realtime-base/realtime-base-0.1.ebuild
+++ b/sys-auth/realtime-base/realtime-base-0.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
inherit user
@@ -17,30 +17,30 @@ IUSE=""
DEPEND=""
RDEPEND="virtual/pam"
+S=${WORKDIR}
+
limitsdfile=40-${PN}.conf
rtgroup=realtime
-S=${WORKDIR}
-
pkg_setup() {
enewgroup ${rtgroup}
}
-print_limitsdfile() {
- printf "# Start of ${limitsdfile} from ${P}\n\n"
- printf "@${rtgroup}\t-\trtprio\t99\n"
- printf "@${rtgroup}\t-\tmemlock\tunlimited\n"
- printf "\n# End of ${limitsdfile} from ${P}\n"
-}
-
src_compile() {
einfo "Generating ${limitsdfile}"
- print_limitsdfile > "${S}/${limitsdfile}"
+ cat > ${limitsdfile} <<- EOF || die
+ # Start of ${limitsdfile} from ${P}
+
+ @${rtgroup} - rtprio 99
+ @${rtgroup} - memlock unlimited
+
+ # End of ${limitsdfile} from ${P}
+ EOF
}
src_install() {
insinto /etc/security/limits.d/
- doins "${S}/${limitsdfile}" || die
+ doins ${limitsdfile}
}
pkg_postinst() {