summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-09-01 17:57:46 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-03 11:26:52 +0200
commit6485edc3edd5e0b7b6311daf3583d71292186a0a (patch)
tree5e5be3ba487808083ab9d3130d59162c0b3f483b /sys-block/arcconf/arcconf-2.06.23167.ebuild
parentsys-kernel/git-sources: Automated version bump to 4.19_rc2. (diff)
downloadgentoo-6485edc3edd5e0b7b6311daf3583d71292186a0a.tar.gz
gentoo-6485edc3edd5e0b7b6311daf3583d71292186a0a.tar.bz2
gentoo-6485edc3edd5e0b7b6311daf3583d71292186a0a.zip
sys-block/arcconf: version bump to 2.06.23167.
Closes: https://bugs.gentoo.org/665028 Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9752
Diffstat (limited to 'sys-block/arcconf/arcconf-2.06.23167.ebuild')
-rw-r--r--sys-block/arcconf/arcconf-2.06.23167.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/arcconf/arcconf-2.06.23167.ebuild b/sys-block/arcconf/arcconf-2.06.23167.ebuild
new file mode 100644
index 000000000000..c928fa4f4135
--- /dev/null
+++ b/sys-block/arcconf/arcconf-2.06.23167.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="v${PV//./_}"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="https://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Microsemi"
+SLOT="0"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/linux_x64"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://storage.microsemi.com/en-us/speed/raid/storage_manager/${PN}_${MY_PV}_zip.php"
+ elog "and place it in your DISTDIR directory."
+}
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists ; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin cmdline/arcconf
+}