summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:38:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:45 +0100
commit03f8640583def61303625a6d8bd6582e009b2642 (patch)
tree28ffc149ab742da77d963ba816eeac8dd4d71717 /sys-block/arcconf
parentsys-apps/tas: drop 1.6.0.200601 (diff)
downloadgentoo-03f8640583def61303625a6d8bd6582e009b2642.tar.gz
gentoo-03f8640583def61303625a6d8bd6582e009b2642.tar.bz2
gentoo-03f8640583def61303625a6d8bd6582e009b2642.zip
sys-block/arcconf: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-block/arcconf')
-rw-r--r--sys-block/arcconf/arcconf-2.01.22270-r2.ebuild41
-rw-r--r--sys-block/arcconf/arcconf-3.07.23971-r1.ebuild36
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-block/arcconf/arcconf-2.01.22270-r2.ebuild b/sys-block/arcconf/arcconf-2.01.22270-r2.ebuild
new file mode 100644
index 000000000000..2b27f5c9eed9
--- /dev/null
+++ b/sys-block/arcconf/arcconf-2.01.22270-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="v${PV//./_}"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+S="${WORKDIR}"
+
+LICENSE="Microsemi"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="fetch mirror bindist"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://storage.microsemi.com/en-us/speed/raid/storage_manager/${PN}_${MY_PV}_zip.php"
+ elog "and place it in your DISTDIR directory."
+}
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists ; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin linux$(usex amd64 '_x64' '')/cmdline/arcconf
+}
diff --git a/sys-block/arcconf/arcconf-3.07.23971-r1.ebuild b/sys-block/arcconf/arcconf-3.07.23971-r1.ebuild
new file mode 100644
index 000000000000..1355deb39497
--- /dev/null
+++ b/sys-block/arcconf/arcconf-3.07.23971-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="v${PV//./_}"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+S="${WORKDIR}/linux_x64"
+
+LICENSE="Microsemi"
+SLOT="0"
+KEYWORDS="-* amd64"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="mirror bindist"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ # LEGACY_VSYSCALL_NONE makes ARCCONF segaultmakes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN !LEGACY_VSYSCALL_NONE"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin arcconf
+}