summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/btrace/btrace-1.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/btrace/btrace-1.1.0.ebuild')
-rw-r--r--sys-block/btrace/btrace-1.1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-block/btrace/btrace-1.1.0.ebuild b/sys-block/btrace/btrace-1.1.0.ebuild
new file mode 100644
index 000000000000..27df22b5b8aa
--- /dev/null
+++ b/sys-block/btrace/btrace-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? ( virtual/latex-base app-text/dvipdfm )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-ldflags-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}