summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-01-30 00:11:45 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-01-30 00:11:45 +0300
commit3bae81c5a07472b2ad5b37252edf84f53e2467dc (patch)
tree09cecf449efbdb08a4b5e1af3ab9b17cbfa5bf1d /sys-block/flashbench
parentdev-games/wfmath: version bump (diff)
downloadgentoo-3bae81c5a07472b2ad5b37252edf84f53e2467dc.tar.gz
gentoo-3bae81c5a07472b2ad5b37252edf84f53e2467dc.tar.bz2
gentoo-3bae81c5a07472b2ad5b37252edf84f53e2467dc.zip
sys-block/flashbench: initial commit
Based on the ebuild from bug 441610 by James Le Cuirot <chewi@gentoo.org>. Package-Manager: portage-2.2.27 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'sys-block/flashbench')
-rw-r--r--sys-block/flashbench/Manifest1
-rw-r--r--sys-block/flashbench/files/flashbench-20120606-Makefile.patch23
-rw-r--r--sys-block/flashbench/flashbench-20120606.ebuild20
-rw-r--r--sys-block/flashbench/metadata.xml10
4 files changed, 54 insertions, 0 deletions
diff --git a/sys-block/flashbench/Manifest b/sys-block/flashbench/Manifest
new file mode 100644
index 000000000000..ae39e7ebbaa8
--- /dev/null
+++ b/sys-block/flashbench/Manifest
@@ -0,0 +1 @@
+DIST flashbench-20120606.tar.xz 17720 SHA256 c7822a19086d5b049f440eba95752641fdfaeaf836f601e6fd545e8a9bf53fcc SHA512 5ae0c38da7a7d7321157eb892e186e665b2dbacad98ffd7f00a72cce985b4ccd2a63c99c00d681cfeb02cce8c1e00f3a3095716c22f7893299f3c24077ad43ce WHIRLPOOL 9e6614f8edcc88a2d5b79b9be3e8eeedb7ed760a370adea2646e992f55d19c4b3269eb32121bb8f1adcd15e8d115636c16818cff2ff2828b8d074f4d04a36a6d
diff --git a/sys-block/flashbench/files/flashbench-20120606-Makefile.patch b/sys-block/flashbench/files/flashbench-20120606-Makefile.patch
new file mode 100644
index 000000000000..0965a75c12c1
--- /dev/null
+++ b/sys-block/flashbench/files/flashbench-20120606-Makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index f83b220..ffe20fa 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+-CC := gcc
+-CFLAGS := -O2 -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter -g2
+-LDFLAGS := -lrt
++CC ?= gcc
++CFLAGS += -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter
++LIBS := -lrt
+
+ all: flashbench erase
+
+@@ -9,7 +9,7 @@ vm.o: vm.c vm.h dev.h
+ flashbench.o: flashbench.c vm.h dev.h
+
+ flashbench: flashbench.o dev.o vm.o
+- $(CC) -o $@ flashbench.o dev.o vm.o $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ flashbench.o dev.o vm.o $(LIBS)
+
+
+ erase: erase.o
diff --git a/sys-block/flashbench/flashbench-20120606.ebuild b/sys-block/flashbench/flashbench-20120606.ebuild
new file mode 100644
index 000000000000..ce12539f6d8b
--- /dev/null
+++ b/sys-block/flashbench/flashbench-20120606.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Tool for benchmarking and classifying flash memory drives"
+HOMEPAGE="http://git.linaro.org/people/arnd.bergmann/flashbench.git"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( ${FILESDIR}/${P}-Makefile.patch )
+
+src_install() {
+ dobin "${PN}"
+ newbin erase "${PN}-erase" # erase is too ambiguous.
+ dodoc README
+}
diff --git a/sys-block/flashbench/metadata.xml b/sys-block/flashbench/metadata.xml
new file mode 100644
index 000000000000..0328a782193f
--- /dev/null
+++ b/sys-block/flashbench/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ksokoban</remote-id>
+ </upstream>
+</pkgmetadata>