summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/hpacucli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/hpacucli')
-rw-r--r--sys-block/hpacucli/Manifest2
-rw-r--r--sys-block/hpacucli/files/hpacucli-wrapper22
-rw-r--r--sys-block/hpacucli/hpacucli-9.30.15.0.ebuild69
-rw-r--r--sys-block/hpacucli/metadata.xml7
4 files changed, 100 insertions, 0 deletions
diff --git a/sys-block/hpacucli/Manifest b/sys-block/hpacucli/Manifest
new file mode 100644
index 000000000000..096dd390c184
--- /dev/null
+++ b/sys-block/hpacucli/Manifest
@@ -0,0 +1,2 @@
+DIST hpacucli-9.30-15.0.i386.rpm 6405071 SHA256 f1019a4a26c7d9adef1761fafb46b3add3034e77d48efe431bd499bbe5609312 SHA512 f628e5ca1f4e598700aaf8896e310e3ee59705d2ad9eae813179c0e873878b3ab6dd317fb34f738f901eb6972e8f4e9428b57a572dd1f8de73660b1c89213ce1 WHIRLPOOL cc41b16426a4298eafbf200a9c437501c8a2eb2456ca4e9d3f278bed64e203dade4e0de7c94a56e14ef20928a9c292440193c1e98071d9aaa661616c0ad6ea64
+DIST hpacucli-9.30-15.0.x86_64.rpm 6367162 SHA256 d25b4fc593e11e00f2ca2b83417b23d1b1e12e6bff3afcda5333b274dea89901 SHA512 ad53b7452feffc7457220b9f1df8fd435637e7d1d61b42bdaffe75e62c8245a127b7a80435a40ac5675f0a64e14cc9a99fa556dbecb0e37ae70dda51927afd6e WHIRLPOOL 0ba12328989bd5dce8eb5d83377768605f931ca78dd0e534bdbf65c93a17536499a7a9ea77816f4640ec86be8bdb620ae578fa14f7f7542c18ef95ac6efa3d27
diff --git a/sys-block/hpacucli/files/hpacucli-wrapper b/sys-block/hpacucli/files/hpacucli-wrapper
new file mode 100644
index 000000000000..c60c205f9cfc
--- /dev/null
+++ b/sys-block/hpacucli/files/hpacucli-wrapper
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+cmd="$(basename "$0")"
+
+HPACUCLI_BASEDIR="/opt/hp/hpacucli"
+HPACUCLI_LOCKDIR="/var/lock/$cmd"
+HPACUCLI_LOCK="${HPACUCLI_LOCKDIR}/CPQACU_MUTEX"
+HPACUCLI_BIN="${HPACUCLI_BASEDIR}/$cmd.bin"
+
+if pgrep -x "$cmd.bin"; then
+ echo "Another instance of $cmd is running! Stop it first."
+ exit 1
+fi
+
+if ! [ -f "${HPACUCLI_LOCK}" ]; then
+ mkdir -p -m 700 "${HPACUCLI_LOCKDIR}"
+ touch "${HPACUCLI_LOCK}"
+fi
+
+export LD_LIBRARY_PATH="${HPACUCLI_BASEDIR}"
+export ACUXE_LOCK_FILES_DIR="${HPACUCLI_LOCKDIR}/"
+exec setarch `uname -m` --uname-2.6 "${HPACUCLI_BIN}" "${@}"
diff --git a/sys-block/hpacucli/hpacucli-9.30.15.0.ebuild b/sys-block/hpacucli/hpacucli-9.30.15.0.ebuild
new file mode 100644
index 000000000000..f449b5ae6461
--- /dev/null
+++ b/sys-block/hpacucli/hpacucli-9.30.15.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit rpm versionator pax-utils
+
+MY_PV=$(replace_version_separator 2 '-')
+
+SRC_URI_BASE="ftp://ftp.hp.com/pub/softlib2/software1/pubsw-linux"
+AMD64_PID="1257348637"
+AMD64_VID="77370"
+X86_PID="414707558"
+X86_VID="77371"
+
+DESCRIPTION="HP Array Configuration Utility Command Line Interface (HPACUCLI, formerly CPQACUXE)"
+HOMEPAGE="http://h18000.www1.hp.com/products/servers/linux/documentation.html"
+SRC_URI="
+ amd64? ( ${SRC_URI_BASE}/p${AMD64_PID}/v${AMD64_VID}/${PN}-${MY_PV}.x86_64.rpm )
+ x86? ( ${SRC_URI_BASE}/p${X86_PID}/v${X86_VID}/${PN}-${MY_PV}.i386.rpm )"
+
+LICENSE="hp-proliant-essentials"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/coreutils
+ sys-process/procps
+ >=sys-apps/util-linux-2.20.1"
+
+S="${WORKDIR}"
+
+HPACUCLI_BASEDIR="/opt/hp/hpacucli"
+QA_PREBUILT="${HPACUCLI_BASEDIR}/*"
+
+src_install() {
+ local MY_S="${S}/opt/compaq/${PN}/bld"
+
+ newsbin "${FILESDIR}"/"${PN}-wrapper" hpacucli
+ dosym /usr/sbin/hpacucli /usr/sbin/hpacuscripting
+
+ exeinto "${HPACUCLI_BASEDIR}"
+ for bin in "${MY_S}"/.hp*; do
+ local basename=$(basename "${bin}")
+ newexe "${bin}" ${basename#.}.bin
+ done
+
+ insinto "${HPACUCLI_BASEDIR}"
+ doins "${MY_S}"/*.so
+
+ dodoc "${MY_S}"/*.txt
+ doman "${S}"/usr/man/man*/*
+
+ cat <<-EOF >"${T}"/45${PN}
+ LDPATH=${HPACUCLI_BASEDIR}
+ EOF
+ doenvd "${T}"/45${PN}
+
+ pax-mark m "${D}/opt/hp/hpacucli/"*
+}
+
+pkg_postinst() {
+ elog
+ elog "For more information regarding this utility, please read"
+ elog "/usr/share/doc/${P}/${PN}-${MY_PV}.noarch.txt"
+ elog
+}
diff --git a/sys-block/hpacucli/metadata.xml b/sys-block/hpacucli/metadata.xml
new file mode 100644
index 000000000000..9981c1918ef7
--- /dev/null
+++ b/sys-block/hpacucli/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>