summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-11 07:26:43 +0000
committerSam James <sam@gentoo.org>2021-03-11 07:29:50 +0000
commit908fab4f4a04e0928a31960231d12331111f3a09 (patch)
tree958d183019af6de45f2c1b8df43bcc3cc4cc1b17 /sys-block/libzbd
parentnet-mail/mlmmj: fix docs (diff)
downloadgentoo-908fab4f4a04e0928a31960231d12331111f3a09.tar.gz
gentoo-908fab4f4a04e0928a31960231d12331111f3a09.tar.bz2
gentoo-908fab4f4a04e0928a31960231d12331111f3a09.zip
sys-block/libzbd: multiple QA fixes
* Define RDEPEND * Move pkgconfig to BDEPEND * Make pkgconfig dependency conditional (only used for GUI * Fix unrecognised configure flags (--enable-gui, not --with-gtk) Closes: https://bugs.gentoo.org/771573 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/libzbd')
-rw-r--r--sys-block/libzbd/libzbd-1.2.0.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sys-block/libzbd/libzbd-1.2.0.ebuild b/sys-block/libzbd/libzbd-1.2.0.ebuild
index 568e9787c1b0..ca893c6e8be5 100644
--- a/sys-block/libzbd/libzbd-1.2.0.ebuild
+++ b/sys-block/libzbd/libzbd-1.2.0.ebuild
@@ -9,17 +9,20 @@ DESCRIPTION="Zoned block device manipulation library and tools"
HOMEPAGE="https://github.com/westerndigitalcorporation/libzbd"
SRC_URI="https://github.com/westerndigitalcorporation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# Examples/tools are GPL-3+, library is LGPL-3+
LICENSE="GPL-3+ LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="gtk"
-DEPEND="virtual/pkgconfig
+# PKG_CHECK_MODULES is only for GTK right now
+# https://github.com/westerndigitalcorporation/libzbd/blob/master/configure.ac#L71
+BDEPEND="gtk? ( virtual/pkgconfig )"
+DEPEND="
>=sys-kernel/linux-headers-4.13
- gtk? ( x11-libs/gtk+:3 )"
-
-PATCHES=(
-)
+ gtk? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}"
src_prepare() {
default
@@ -28,7 +31,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_with gtk gtk3) \
+ $(use_enable gtk gui) \
--disable-static
}