summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:19:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:19:22 +0200
commit129927402d4aa28f64ec936a2fb720c622e67aed (patch)
treecad6418b2ec6f01a4cfd546d78de20eed5c93f92 /sys-block/mbuffer
parentsys-apps/irqbalance: Bump to v1.4.0 (diff)
downloadgentoo-129927402d4aa28f64ec936a2fb720c622e67aed.tar.gz
gentoo-129927402d4aa28f64ec936a2fb720c622e67aed.tar.bz2
gentoo-129927402d4aa28f64ec936a2fb720c622e67aed.zip
sys-block/mbuffer: Bump to v20180505
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'sys-block/mbuffer')
-rw-r--r--sys-block/mbuffer/Manifest1
-rw-r--r--sys-block/mbuffer/mbuffer-20180505.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-block/mbuffer/Manifest b/sys-block/mbuffer/Manifest
index 03129a42e2c6..858bb66989eb 100644
--- a/sys-block/mbuffer/Manifest
+++ b/sys-block/mbuffer/Manifest
@@ -2,3 +2,4 @@ DIST mbuffer-20150412.tgz 122935 BLAKE2B c57708861a9fc049fd4f3aa9c1229798a82e866
DIST mbuffer-20171011.tgz 136630 BLAKE2B ba69435684b8c844701a51c5a77d0f5ecbf8bef3ca9b9739a63309524b14d0cbbeba422cee1c5d69f1029a42c18d089cea0bcc46dbeba7f51767df3a815f7de7 SHA512 398d7545388a94b4f8961193192cd5e1139b84f31c7699c2b7f66b84a40488a2e70c88a2a70578bd95375e11efc87978a5f6fec805dbbc5f1fea460b3a9c68c4
DIST mbuffer-20180318.tgz 137259 BLAKE2B bec1f6acc68c3c9cf617dd7a752644628d088541c20816737ea1533eb0e9c92b76ef2dd037912501c29056994443e3ad66b1e7f4456e0f40687b32e4c6a12cf1 SHA512 ac71876aa0bea3acce8ea00c3848783b752991a0e60ebc4245277fd435c2c9e08c79cc5f47c996e590e711ca1bd652ded075c24ca820efe845f578b106c43594
DIST mbuffer-20180410.tgz 140026 BLAKE2B d271b4c744d5c54aebaea9a68a674df184ac460f879ac4788afaca732466c95dd958145ffcb42155ed998cab771a5b0e70a57a6b479d244156afe6232c37b154 SHA512 88fdad5b767bc4dabdbe3300cf3de99a56d137ac991aa5be7ba383fc2447ec01cb43853f31ec88be3bf0cfa736753afe8bd5ef0a5abb386521f2d3316b781d74
+DIST mbuffer-20180505.tgz 140183 BLAKE2B 4c575c9654f15b4f81357fff21f41170627f6747313a462a76abbb8f5125a2e97549a9975aa67a59b402af6651b4e27b17e4ac7ea72b45620b43542ebccf9107 SHA512 b2f541332afadb42bbd2452d2079373f9d8ad44f0fe5eab2934cf4c46c6b2e4ec18c862ed385ba10e5b820efeab28c982bcf4ffa37a9cf70c5c92b5aabde7f4f
diff --git a/sys-block/mbuffer/mbuffer-20180505.ebuild b/sys-block/mbuffer/mbuffer-20180505.ebuild
new file mode 100644
index 000000000000..3b1fd2aa6a99
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20180505.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="http://www.maier-komor.de/mbuffer.html"
+SRC_URI="http://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ssl test"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/openssl:0 )"
+
+REQUIRED_USE="test? ( ssl )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+)
+
+src_prepare() {
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ export MAKEOPTS=-j1
+
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+ ewarn "Some tests may fail with FEATURES=usersandbox or"
+ ewarn "FEATURES=network-sandbox; Skipping tests because"
+ ewarn "test suite would hang forever in such environments!"
+ return 0;
+ fi
+
+ default
+}
+
+pkg_postinst() {
+ if ! has_version "app-arch/mt-st"; then
+ elog ""
+ elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+ fi
+}