summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-21 13:31:39 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-21 13:40:27 -0400
commit31d1f32ade6a3b11378453363b19dccaecb54890 (patch)
tree3e2097c00f6d22bcafde78f3ed09c6942cd0b936 /sys-block/mbuffer
parentsys-apps/x86info: Version bump to 1.31 (diff)
downloadgentoo-31d1f32ade6a3b11378453363b19dccaecb54890.tar.gz
gentoo-31d1f32ade6a3b11378453363b19dccaecb54890.tar.bz2
gentoo-31d1f32ade6a3b11378453363b19dccaecb54890.zip
sys-block/mbuffer: Version bump to 20220418
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-block/mbuffer')
-rw-r--r--sys-block/mbuffer/Manifest1
-rw-r--r--sys-block/mbuffer/mbuffer-20220418.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-block/mbuffer/Manifest b/sys-block/mbuffer/Manifest
index 21aa08ed1c99..0335942b5c39 100644
--- a/sys-block/mbuffer/Manifest
+++ b/sys-block/mbuffer/Manifest
@@ -1 +1,2 @@
DIST mbuffer-20211018.tgz 149348 BLAKE2B 0b9fbd6b48198cb8def22687420c61ed2e60f7be5ba10365bdc324f4de33c5e1fafdad93c53031d8fb4cb2d2cbb1695e517761eb6859f2f80ffabbeacb4783c9 SHA512 9e08bec5945e7495b469578381d154c2820aed51d1afbf5d0b9bdd693acc095bb4b69e376f5e6a9a8e239f5b9adfcdc7e091d692006248447490ce0547bb7109
+DIST mbuffer-20220418.tgz 149535 BLAKE2B 8c7eacae791bef8ac6cd2ce57e6a5fbda7c7c233c37ccc504ad6584385df4b4df49aaf67f2d2dc7a3ee9f7e1431ba511847646a4c92616c1a4af5ac094e029e9 SHA512 aad7f764c82e3bdd4ee3fc5ac8174e716fd44cdb0418f1994d3f506d2e58264a13e15596bc8e78e9e8bb2d181875294448085bab122a2a31356d4336bb8b54a4
diff --git a/sys-block/mbuffer/mbuffer-20220418.ebuild b/sys-block/mbuffer/mbuffer-20220418.ebuild
new file mode 100644
index 000000000000..1fb048d9a999
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20220418.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug ssl test"
+
+REQUIRED_USE="test? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+ "${FILESDIR}/${PN}-20200929-find-OBJDUMP.patch"
+)
+
+src_prepare() {
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+ ewarn "Some tests may fail with FEATURES=usersandbox or"
+ ewarn "FEATURES=network-sandbox; Skipping tests because"
+ ewarn "test suite would hang forever in such environments!"
+ return 0;
+ fi
+
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ local -x MAKEOPTS=-j1
+
+ default
+}
+
+pkg_postinst() {
+ if ! has_version "app-arch/mt-st"; then
+ elog ""
+ elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+ fi
+}