summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 18:00:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 18:00:37 +0200
commit0a337293291d083bfb82b13bb9e71207ef199e94 (patch)
treede60368e7ac24a1d16958ae5262830b736330059 /sys-block/nbd/nbd-3.15.3.ebuild
parentsys-apps/diffutils: Bump to version 3.6 (diff)
downloadgentoo-0a337293291d083bfb82b13bb9e71207ef199e94.tar.gz
gentoo-0a337293291d083bfb82b13bb9e71207ef199e94.tar.bz2
gentoo-0a337293291d083bfb82b13bb9e71207ef199e94.zip
sys-block/nbd: Bump to version 3.15.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-block/nbd/nbd-3.15.3.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.15.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.15.3.ebuild b/sys-block/nbd/nbd-3.15.3.ebuild
new file mode 100644
index 000000000000..9517632c1104
--- /dev/null
+++ b/sys-block/nbd/nbd-3.15.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug zlib"
+
+# gnutls is an automagic dep.
+RDEPEND=">=dev-libs/glib-2.0
+ >=net-libs/gnutls-2.12.0
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-lfs
+ $(use_enable !debug syslog)
+ $(use_enable debug)
+ $(use_enable zlib gznbd)
+ )
+ econf "${myeconfargs[@]}"
+}