summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-02 22:04:52 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-02 22:06:53 -0600
commit4b8605982b246ed5c6ff895fa32b4e603ca602ad (patch)
tree396747245fb86bba369343105ea80db31fa70e40 /sys-block/open-isns
parentapp-emulation/lxd: Bump to 2.7 (diff)
downloadgentoo-4b8605982b246ed5c6ff895fa32b4e603ca602ad.tar.gz
gentoo-4b8605982b246ed5c6ff895fa32b4e603ca602ad.tar.bz2
gentoo-4b8605982b246ed5c6ff895fa32b4e603ca602ad.zip
sys-block/open-isns: fix builds on musl
This patch is in place as the code path it changes fixes is only accessible on musl based systems and only fails to compile on musl based systems. Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-block/open-isns')
-rw-r--r--sys-block/open-isns/files/open-isns-0.97-musl.patch11
-rw-r--r--sys-block/open-isns/open-isns-0.97.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/sys-block/open-isns/files/open-isns-0.97-musl.patch b/sys-block/open-isns/files/open-isns-0.97-musl.patch
new file mode 100644
index 000000000000..098ade40a213
--- /dev/null
+++ b/sys-block/open-isns/files/open-isns-0.97-musl.patch
@@ -0,0 +1,11 @@
+--- ./include/libisns/util.h.orig
++++ ./include/libisns/util.h
+@@ -114,6 +114,6 @@
+ # define ntohll(x) __bswap_64(x)
+ # endif
+ # else
+-# include <sys/endian.h>
++# include <endian.h>
+ # define htonll(x) htobe64(x)
+ # define ntohll(x) be64toh(x)
+ # endif
diff --git a/sys-block/open-isns/open-isns-0.97.ebuild b/sys-block/open-isns/open-isns-0.97.ebuild
index fd746860ac16..c742bff295f3 100644
--- a/sys-block/open-isns/open-isns-0.97.ebuild
+++ b/sys-block/open-isns/open-isns-0.97.ebuild
@@ -20,6 +20,8 @@ DEPEND="
slp? ( net-libs/openslp )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-${PV}-musl.patch" )
+
src_configure() {
use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
append-lfs-flags