summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-25 14:03:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-25 14:28:31 +0100
commit8556ea8399e782d2c13a15719c58a153c645b3c6 (patch)
tree086ce286edfb1481af37637e7ebed55165e63c8c /sys-block/open-isns
parentnet-irc/hexchat: Fixed python plugins with python-3.8 (diff)
downloadgentoo-8556ea8399e782d2c13a15719c58a153c645b3c6.tar.gz
gentoo-8556ea8399e782d2c13a15719c58a153c645b3c6.tar.bz2
gentoo-8556ea8399e782d2c13a15719c58a153c645b3c6.zip
sys-block/open-isns: respect AR
Closes: https://bugs.gentoo.org/721492 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block/open-isns')
-rw-r--r--sys-block/open-isns/files/open-isns-0.100-respect-AR.patch30
-rw-r--r--sys-block/open-isns/open-isns-0.100.ebuild2
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/open-isns/files/open-isns-0.100-respect-AR.patch b/sys-block/open-isns/files/open-isns-0.100-respect-AR.patch
new file mode 100644
index 000000000000..66e52e548125
--- /dev/null
+++ b/sys-block/open-isns/files/open-isns-0.100-respect-AR.patch
@@ -0,0 +1,30 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -33,6 +33,7 @@ else
+ SOLIB_VERSION_OPTS =
+ endif
+
++AR = @AR@
+ CC = @CC@
+ CPPFLAGS= @CPPFLAGS@
+ CFLAGS = @CFLAGS@ -I. -Iinclude -I$(srcdir) -I$(srcdir)/include
+@@ -161,7 +162,7 @@ solib-message.o: message.c
+
+ ifeq ($(BUILD_STATIC),1)
+ $(LIB): $(LIBOBJS)
+- ar cr $@ $(LIBOBJS)
++ $(AR) cr $@ $(LIBOBJS)
+ else
+ $(LIB):
+ endif
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,6 +4,7 @@ AC_CONFIG_AUX_DIR([aclocal])
+
+ AC_CONFIG_HEADER(config.h)
+
++AM_PROG_AR
+ AC_PROG_CC
+ AC_CANONICAL_HOST
+ AC_C_BIGENDIAN
+
diff --git a/sys-block/open-isns/open-isns-0.100.ebuild b/sys-block/open-isns/open-isns-0.100.ebuild
index 878669c9073a..63213dbfd792 100644
--- a/sys-block/open-isns/open-isns-0.100.ebuild
+++ b/sys-block/open-isns/open-isns-0.100.ebuild
@@ -25,6 +25,8 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-0.98-libressl-compatibility.patch"
+ "${FILESDIR}/${PN}-0.100-respect-AR.patch"
+
# Upstream patches (can usually be removed with next version bump)
"${FILESDIR}"/${P}-no_Werror.patch
)