summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-04 21:51:46 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-04 21:54:06 +0100
commit3fe8e9910002b6523d995512a646b063565d0447 (patch)
tree6f3f39b38eb75b9e241504d85c69e35208a99b04 /sys-block/partimage/files
parentnet-print/splix: fix for big-endian hosts (diff)
downloadgentoo-3fe8e9910002b6523d995512a646b063565d0447.tar.gz
gentoo-3fe8e9910002b6523d995512a646b063565d0447.tar.bz2
gentoo-3fe8e9910002b6523d995512a646b063565d0447.zip
sys-block/partimage: add OpenSSL 1.1+ compatibility
- EAPI bumped to EAPI=6 - OpenSSL 1.1+ compatibility added Closes: https://bugs.gentoo.org/674074 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block/partimage/files')
-rw-r--r--sys-block/partimage/files/partimage-0.6.9-openssl-1.1-compatibility.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-block/partimage/files/partimage-0.6.9-openssl-1.1-compatibility.patch b/sys-block/partimage/files/partimage-0.6.9-openssl-1.1-compatibility.patch
new file mode 100644
index 000000000000..af4d9c153df2
--- /dev/null
+++ b/sys-block/partimage/files/partimage-0.6.9-openssl-1.1-compatibility.patch
@@ -0,0 +1,41 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -240,7 +240,7 @@ if test "$SSL" = "yes"; then
+ AC_CHECKING([ for SSL Library and Header files ... ])
+ AC_SEARCH_HEADERS(rsa.h crypto.h x509.h pem.h ssl.h err.h,
+ $SSL_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include,
+- [ AC_CHECK_LIB(crypto, CRYPTO_lock, [LIBS="$LIBS -lcrypto"],
++ [ AC_CHECK_LIB(crypto, X509_new, [LIBS="$LIBS -lcrypto"],
+ AC_MSG_ERROR([ Required for SSL Crypto Library not found. ])
+ )
+ AC_CHECK_LIB(ssl, SSL_CTX_new,
+--- a/src/client/netclient.cpp
++++ b/src/client/netclient.cpp
+@@ -43,7 +43,11 @@ CNetClient::CNetClient(bool bMustLogin, bool bUseSSL):CNet()
+ {
+ showDebug(3, "initializing client ssl\n");
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv2_client_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_client_method();
++#else
++ meth = TLS_client_method();
++#endif
+ SSL_load_error_strings();
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+--- a/src/server/netserver.cpp
++++ b/src/server/netserver.cpp
+@@ -39,7 +39,11 @@ CNetServer::CNetServer(unsigned short int port):CNet()
+ {
+ SSL_load_error_strings();
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv23_server_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_server_method();
++#else
++ meth = TLS_server_method();
++#endif
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+ {