summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/scsirastools/scsirastools-1.5.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/scsirastools/scsirastools-1.5.6.ebuild')
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.6.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-block/scsirastools/scsirastools-1.5.6.ebuild b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
new file mode 100644
index 000000000000..0c3d2c1ed749
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ # this builds a really old mdadm
+ sed -i \
+ -e '/RPMB/d' \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ "${S}"/Makefile.am || die "sed Makefile.am failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f "${S}"/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i "${S}"/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || die "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm -f "${D}"${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}