summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-19 02:21:36 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-19 02:21:36 -0400
commit45c8ffbd7ce3d08a80af90255e71dfe57eb22a91 (patch)
treedbff36e8fd1717226d1d6fca040b5094af6b9843 /sys-block/smp_utils
parentsys-fs/cryptsetup: fix build w/newer glibc #580228 (diff)
downloadgentoo-45c8ffbd7ce3d08a80af90255e71dfe57eb22a91.tar.gz
gentoo-45c8ffbd7ce3d08a80af90255e71dfe57eb22a91.tar.bz2
gentoo-45c8ffbd7ce3d08a80af90255e71dfe57eb22a91.zip
sys-block/smp_utils: fix build w/newer glibc #580258
Diffstat (limited to 'sys-block/smp_utils')
-rw-r--r--sys-block/smp_utils/files/smp_utils-0.98-sysmacros.patch54
-rw-r--r--sys-block/smp_utils/smp_utils-0.98.ebuild4
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-block/smp_utils/files/smp_utils-0.98-sysmacros.patch b/sys-block/smp_utils/files/smp_utils-0.98-sysmacros.patch
new file mode 100644
index 000000000000..7eaa418f91cd
--- /dev/null
+++ b/sys-block/smp_utils/files/smp_utils-0.98-sysmacros.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/580258
+
+From 6c6f341d84f1e4c2c67fed98f09debe086fe9a47 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 19 Apr 2016 02:19:20 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
+
+These funcs are defined in that header, so include it to avoid errors:
+../lib/.libs/libsmputils1.so: undefined reference to 'minor'
+---
+ lib/smp_aac_io.c | 1 +
+ lib/smp_lin_bsg.c | 1 +
+ lib/smp_mptctl_io.c | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/lib/smp_aac_io.c b/lib/smp_aac_io.c
+index 442eadf..e3d9710 100644
+--- a/lib/smp_aac_io.c
++++ b/lib/smp_aac_io.c
+@@ -6,6 +6,7 @@
+ #include <stddef.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+diff --git a/lib/smp_lin_bsg.c b/lib/smp_lin_bsg.c
+index 0995ded..89a92cc 100644
+--- a/lib/smp_lin_bsg.c
++++ b/lib/smp_lin_bsg.c
+@@ -40,6 +40,7 @@
+ #include <fcntl.h>
+ //#include <curses.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+diff --git a/lib/smp_mptctl_io.c b/lib/smp_mptctl_io.c
+index 5512913..def386d 100644
+--- a/lib/smp_mptctl_io.c
++++ b/lib/smp_mptctl_io.c
+@@ -15,6 +15,7 @@
+ #include <fcntl.h>
+ //#include <curses.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+--
+2.7.4
+
diff --git a/sys-block/smp_utils/smp_utils-0.98.ebuild b/sys-block/smp_utils/smp_utils-0.98.ebuild
index 61c39fdbe328..ef4b65286cdb 100644
--- a/sys-block/smp_utils/smp_utils-0.98.ebuild
+++ b/sys-block/smp_utils/smp_utils-0.98.ebuild
@@ -18,3 +18,7 @@ IUSE="static-libs"
DOCS=( AUTHORS ChangeLog COVERAGE CREDITS README )
AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sysmacros.patch #580258
+)