summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@fastmail.com>2017-01-29 17:02:12 +0000
committerMichael Palimaka <kensington@gentoo.org>2017-01-30 04:25:02 +1100
commit83b41f95c034da25f87946f1b490df7f03a0ba9c (patch)
tree83e4c56bf6477fc78655a827e425c47367fde57e /sys-block/whdd/whdd-3.0.ebuild
parentdev-python/pygments: dropped ~x86-interix (diff)
downloadgentoo-83b41f95c034da25f87946f1b490df7f03a0ba9c.tar.gz
gentoo-83b41f95c034da25f87946f1b490df7f03a0ba9c.tar.bz2
gentoo-83b41f95c034da25f87946f1b490df7f03a0ba9c.zip
sys-block/whdd: export CC to build system
Use tc-export function from toolchain-funcs eclass to export CC as environment variable. This is needed because build system of whdd (>=3.0) has no configure script, but straight makefile and Portage doesn't automatically export CC and other build-related environment variables.
Diffstat (limited to 'sys-block/whdd/whdd-3.0.ebuild')
-rw-r--r--sys-block/whdd/whdd-3.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-3.0.ebuild b/sys-block/whdd/whdd-3.0.ebuild
index 6c4ff079329a..822e0f269d4c 100644
--- a/sys-block/whdd/whdd-3.0.ebuild
+++ b/sys-block/whdd/whdd-3.0.ebuild
@@ -7,6 +7,8 @@ EAPI=6
DESCRIPTION="Diagnostic and recovery tool for block devices"
HOMEPAGE="https://whdd.github.io"
+inherit toolchain-funcs
+
if [[ ${PV} == 9999 ]]
then
EGIT_REPO_URI="https://github.com/${PN}/${PN}"
@@ -26,3 +28,8 @@ DEPEND="
sys-libs/ncurses:0=[unicode]"
RDEPEND="${DEPEND}
sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}