summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@fastmail.com>2017-01-08 01:37:59 +0000
committerMichael Palimaka <kensington@gentoo.org>2017-01-30 02:22:04 +1100
commitce337f2df79ec528640932932898dce35078e029 (patch)
tree094354708b74dd1eb71b4732df233bb0c67c4061 /sys-block/whdd
parentsys-block/whdd: 9999: specify ncurses slot in DEPEND (diff)
downloadgentoo-ce337f2df79ec528640932932898dce35078e029.tar.gz
gentoo-ce337f2df79ec528640932932898dce35078e029.tar.bz2
gentoo-ce337f2df79ec528640932932898dce35078e029.zip
sys-block/whdd: add 3.0 ebuild
3.0 ebuild is exact copy of -9999 live ebuild which handles case of tagged releases.
Diffstat (limited to 'sys-block/whdd')
-rw-r--r--sys-block/whdd/Manifest1
-rw-r--r--sys-block/whdd/whdd-3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
index 09ecaa809021..927a701a65e3 100644
--- a/sys-block/whdd/Manifest
+++ b/sys-block/whdd/Manifest
@@ -1 +1,2 @@
DIST whdd-2.2.tar.gz 33317 SHA256 49d615e46117f1271aac22a063703e87fab749e5357a0c5bb4a369e39d7c9241 SHA512 ab30c1e418cb7ba9881b1a91b99d0b1d5389172c4d5802be69d98cb9c16f1282ff7808e2b40bb937987a9d3ad9fa7f20e630d19307eb0aa1090cff531a904d4a WHIRLPOOL c7d9eee7a21e6390a0c1a5befe5bcb17bf326c0b17ae89164452d5e70a94567cb987ecaf17c90ca0631e3ef1f0d958f8d46881f65169179202c84bedb826719b
+DIST whdd-3.0.tar.gz 45865 SHA256 2e030e7fccb54b6911d90fe44980938b5018e4103b54d4d73b334cb646134f41 SHA512 f53888383dc0ed4158c13a064a2cd45e8e312b389bb79c1bfc9ce86c8a61a195fe5003821c868715316eeaba7ee5bcb387324fb6577af7f875679789cd5af5d7 WHIRLPOOL 6bdc74a77d6b05d9845688e57c34304b42a3593b15d1e61f21aace17434ffe230dd5823e4509c9a2339e687b006fb23b33a03209af983b2307c03934504f7f24
diff --git a/sys-block/whdd/whdd-3.0.ebuild b/sys-block/whdd/whdd-3.0.ebuild
new file mode 100644
index 000000000000..6c4ff079329a
--- /dev/null
+++ b/sys-block/whdd/whdd-3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"