summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2016-01-01 22:24:43 +0100
committerJauhien Piatlicki <jauhien@gentoo.org>2016-01-01 22:26:35 +0100
commit4f18181e42b159d872fe574b77085f4fe0a06717 (patch)
tree038bba44c37b82db266cbb715073f75e96697f19 /sys-block/zram-init/zram-init-3.6.ebuild
parentdev-lang/rust-bin: version bump, sync with gentoo-rust overlay (diff)
downloadgentoo-4f18181e42b159d872fe574b77085f4fe0a06717.tar.gz
gentoo-4f18181e42b159d872fe574b77085f4fe0a06717.tar.bz2
gentoo-4f18181e42b159d872fe574b77085f4fe0a06717.zip
sys-block/zram-init: version bump, sync with mv overlay
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-block/zram-init/zram-init-3.6.ebuild')
-rw-r--r--sys-block/zram-init/zram-init-3.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-block/zram-init/zram-init-3.6.ebuild b/sys-block/zram-init/zram-init-3.6.ebuild
new file mode 100644
index 000000000000..ab1468e62fa1
--- /dev/null
+++ b/sys-block/zram-init/zram-init-3.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="mirror"
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ eapply_user
+}
+
+src_install() {
+ dosbin sbin/*
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}