summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-26 11:42:19 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-26 11:43:15 +0100
commit0c59d1cefdf63ef395b70993f81710112a9f5582 (patch)
tree056c808471bb70a5192960fc735e7736b0b12655 /sys-block
parentsys-apps/dbus: user-session is now safe (diff)
downloadgentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.tar.gz
gentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.tar.bz2
gentoo-0c59d1cefdf63ef395b70993f81710112a9f5582.zip
sys-block/storcli: bump to v7.1211
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/storcli/Manifest1
-rw-r--r--sys-block/storcli/storcli-7.1211.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-block/storcli/Manifest b/sys-block/storcli/Manifest
index 0f17d3909959..10c654368ba1 100644
--- a/sys-block/storcli/Manifest
+++ b/sys-block/storcli/Manifest
@@ -8,3 +8,4 @@ DIST storcli-7.0504.zip 40558670 BLAKE2B 3cd54b47b42e5bb8329ccd4b09a6c0863347a04
DIST storcli-7.0606.zip 36634159 BLAKE2B 56cae14537872ef23d8ddc6a0790b727abdf4abecd06b9d1615dc4ad0a554a48bdd077772181d2f0ad9bbe90f015130b4a62caa16b1f02d042403cb6ca389e04 SHA512 ef8bc6b275bb915707624d73d802e84e7a04da087d275055916f047f16d15f1303047c9eb53eae8de88da97ce82fc79616822888fc320af7ba54ad6aa2999996
DIST storcli-7.0709.zip 25844769 BLAKE2B f44791d0813f348068a89a14a0ea457667ab8e224da09a458bfd1126f5e1d9f19655f5392a8d2a8a04ae07f76fc3c91abcdbd48a058c8e9d517c504de8688e66 SHA512 c3995110b592bbf6e58a0e54f62ddbdbb025c6d27ce56111a40d9eb04b7d5ee7a9bfc76e449b0b4900e1082f20df8e06a852a3fe0efc1114158d104036f6033e
DIST storcli-7.1017.zip 36266095 BLAKE2B e1bb4c6bbd19712530fc8d3d7917bf943221f121d0a7d5d3e44205f73bab408d7e4ff94d8cac479a1b834b82e8bdb6661805ca13f1695f8bad52d69d2c988fe9 SHA512 fb4b45fa577417627e67d20bbfa2e07512fe600ffeb9d21e11a80e25208f17b56fb25fa74a9777622c72012a605813b0206a990a6d4191f6b57371bd1d72fd6b
+DIST storcli-7.1211.zip 36988201 BLAKE2B 487dda0c78af60d96dc6eb8bc0c7074dd99719acc4faf10027430ea80a5d1cb76e6bdc9eaf0931967c5cdf10d80ee824f45118144bfc032a4ddce52d678df354 SHA512 f28ae41adf2286153ecd57f7d022940069356c9636e45aaae4ae45215487bbb8e3dea51fa4aa00b9e9340069036c1be21b186ce177e0fd0a6a0bb786cb58181f
diff --git a/sys-block/storcli/storcli-7.1211.ebuild b/sys-block/storcli/storcli-7.1211.ebuild
new file mode 100644
index 000000000000..6646f7cbbfd4
--- /dev/null
+++ b/sys-block/storcli/storcli-7.1211.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pax-utils
+
+# Upstream is still using strange version numbers
+MY_PV="007.1211.0000.0000"
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_PV}_Unified_StorCLI.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/7.12"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli
+ ${MY_STORCLI_BASEDIR:1}/storcli32"
+QA_PREBUILT=${QA_PRESTRIPPED}
+
+src_unpack() {
+ mkdir srcfiles || die
+ pushd srcfiles &>/dev/null || die
+ default
+ mv Unified_storcli_all_os/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storcli_*.deb"
+ popd &>/dev/null || die
+
+ rm -rf srcfiles || die
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.xz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+
+ if use x86; then
+ doexe storcli
+ elif use amd64; then
+ # 32-bit version is less crashy than the 64bit (bug #656494)
+ newexe storcli storcli32
+ newexe storcli64 storcli
+ fi
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ pax-mark m "${D%/}${MY_STORCLI_BASEDIR}"/storcli
+}