summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-21 18:40:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-21 18:42:25 +0100
commit1e9e2ee79e046188ea7fd5e03499f8e37ed64972 (patch)
treed00145a02a49f9c8bf53247022bb1f6454d593cc /sys-block
parentprofiles/arch/amd64-fbsd: Mask media-libs/xine-lib/[fusionsound] (diff)
downloadgentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.tar.gz
gentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.tar.bz2
gentoo-1e9e2ee79e046188ea7fd5e03499f8e37ed64972.zip
sys-block/open-iscsi: Bump to v2.0.876
Closes: https://bugs.gentoo.org/645910 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/Manifest1
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch61
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch92
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.876.ebuild121
4 files changed, 275 insertions, 0 deletions
diff --git a/sys-block/open-iscsi/Manifest b/sys-block/open-iscsi/Manifest
index c32070244d86..e8a6d18310e6 100644
--- a/sys-block/open-iscsi/Manifest
+++ b/sys-block/open-iscsi/Manifest
@@ -2,3 +2,4 @@ DIST open-iscsi-2.0-872.tar.gz 900081 BLAKE2B 6a4911347c55c1c4906350247ae7d92c2a
DIST open-iscsi-2.0-873.tar.gz 667069 BLAKE2B edb427f8483c31499cdde644bbf8d658952952fa8d52a232537e7e6ec71d2d237dcd4e8759de21b65cac757678c7d71c22bd2fe71ed1e7ac152ae8396f080061 SHA512 4e67116cb7dd49381c9279645e5a661f05596ae6be3b832772089828b3764ca2d04b5dea1bcc337071efb52c3c75a6fb943136c659ee59500f3a198ed0dcea6b
DIST open-iscsi-2.0.874.tar.gz 625039 BLAKE2B 39e4b818b1c977d43aa6490acd4d65e688c8cd03a7ae4c03d18d6b81aa76773b0a1227b3e8d975f2a14108075bb680434ded5337db296839bd5be012130df9df SHA512 66d8a52b6401229d51873f1ee0f4e7259a8ed584800403a41741c7eeedc0ec21a2b116671cb7259f60918d083ffb46d76860236a1b10fbb94a4c1d61bddae1ae
DIST open-iscsi-2.0.875.tar.gz 635121 BLAKE2B 34a7083087c53ed0e59d293d26efe166b09c5ea18b6022869cc9ff3d2edb2fb8b69e2c1ce6c9011bd20fc590b02dafd6d7c13d8bfa1eae6408c4bace13992e5e SHA512 1709011d7d12d3dd9278a0d775af064d5f7da37357f35d6d5c5b3aa8ec16385c28b201b1261f4581dbbbbca3d815015ed8696e1694aa19f3231132f90d1e5b36
+DIST open-iscsi-2.0.876.tar.gz 576111 BLAKE2B 2fbe4f37e91730d15bad77feeb9a418a8bbf709582598571a5905080eb60649f3ece6a52e9cf94a28128f2b0bc30093e67f6a47624545243b10bcebe318750ac SHA512 f9319016bd6abf3bf675ad050b0489095a21db58c93f9baaca6adc239129ad08f8e18ed96c91c36406e5c42d35118e67dfde6d3c37e97027467c4472db3b2422
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch
new file mode 100644
index 000000000000..2cfa43622853
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.876-Makefiles.patch
@@ -0,0 +1,61 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -69,9 +69,9 @@ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ iscsistart.o statics.o
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lrt $(ISCSI_LIB)
+ clean:
+- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
++ $(RM) *.o $(PROGRAMS) .depend $(LIBSYS)
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -10,9 +10,9 @@ iscsi-iname: md5.o iscsi-iname.o
+ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(DBM_LIB) -o $@
+
+ clean:
+- rm -f *.o $(PROGRAMS) .depend
++ $(RM) *.o $(PROGRAMS) .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/fwparam_ibft/Makefile
++++ b/utils/fwparam_ibft/Makefile
+@@ -41,11 +41,11 @@ LDFLAGS += -L$(TOPDIR)/libopeniscsiusr -liscsiusr
+ all: $(OBJS)
+
+ clean:
+- rm -f *.o $(CLEANFILES) .depend
++ $(RM) *.o $(CLEANFILES) .depend
+
+ $(OBJS): prom_parse.tab.h prom_parse.h fwparam_ibft.h
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--- a/utils/sysdeps/Makefile
++++ b/utils/sysdeps/Makefile
+@@ -8,9 +8,9 @@ SYSDEPS_OBJS=sysdeps.o
+ all: $(SYSDEPS_OBJS)
+
+ clean:
+- rm -f *.o .depend
++ $(RM) *.o .depend
+
+ depend:
+- gcc $(CFLAGS) -M `ls *.c` > .depend
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+--
+2.16.2
+
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch
new file mode 100644
index 000000000000..7bb0c5d6e779
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.876-musl-fixes.patch
@@ -0,0 +1,92 @@
+--- a/usr/idbm.c
++++ b/usr/idbm.c
+@@ -27,2 +27,3 @@
+ #include <errno.h>
++#include <fcntl.h>
+ #include <dirent.h>
+--- a/usr/iscsiadm.c
++++ b/usr/iscsiadm.c
+@@ -3269,2 +3269,3 @@
+ int do_discover = 0, sub_mode = -1;
++ int argerror = 0;
+ int portal_type = -1;
+@@ -3458,2 +3459,5 @@
+ usage(0);
++ case '?':
++ log_error("unrecognized character '%c'", optopt);
++ argerror = 1;
+ }
+@@ -3473,4 +3477,3 @@
+
+- if (optopt) {
+- log_error("unrecognized character '%c'", optopt);
++ if (argerror) {
+ rc = ISCSI_ERR_INVAL;
+--- a/utils/fwparam_ibft/fwparam_ppc.c
++++ b/utils/fwparam_ibft/fwparam_ppc.c
+@@ -358,3 +358,3 @@
+ */
+- qsort(niclist, nic_count, sizeof(char *), (__compar_fn_t)nic_cmp);
++ qsort(niclist, nic_count, sizeof(char *), (int (*)(const void *, const void *))nic_cmp);
+
+--- a/iscsiuio/src/unix/libs/bnx2x.c
++++ b/iscsiuio/src/unix/libs/bnx2x.c
+@@ -44,3 +44,3 @@
+ #include <linux/sockios.h>
+-#include <linux/ethtool.h>
++#include "ethtool-compat.h"
+ #include <sys/mman.h>
+--- /dev/null
++++ b/iscsiuio/src/unix/libs/ethtool-compat.h
+@@ -0,0 +1,51 @@
++/*
++ * ethtool-compat.h: adopted from
++ # ethtool.h: Defines for Linux ethtool.
++ *
++ * Copyright (C) 1998 David S. Miller (davem@redhat.com)
++ * Copyright 2001 Jeff Garzik <jgarzik@pobox.com>
++ * Portions Copyright 2001 Sun Microsystems (thockin@sun.com)
++ * Portions Copyright 2002 Intel (eli.kupermann@intel.com,
++ * christopher.leech@intel.com,
++ * scott.feldman@intel.com)
++ * Portions Copyright (C) Sun Microsystems 2008
++ */
++
++#include <linux/types.h>
++#include <netinet/if_ether.h>
++
++#define ETHTOOL_FWVERS_LEN 32
++#define ETHTOOL_BUSINFO_LEN 32
++#define ETHTOOL_EROMVERS_LEN 32
++
++struct ethtool_drvinfo {
++ __u32 cmd;
++ char driver[32];
++ char version[32];
++ char fw_version[ETHTOOL_FWVERS_LEN];
++ char bus_info[ETHTOOL_BUSINFO_LEN];
++ char erom_version[ETHTOOL_EROMVERS_LEN];
++ char reserved2[12];
++ __u32 n_priv_flags;
++ __u32 n_stats;
++ __u32 testinfo_len;
++ __u32 eedump_len;
++ __u32 regdump_len;
++};
++
++struct ethtool_tcpip4_spec {
++ __be32 ip4src;
++ __be32 ip4dst;
++ __be16 psrc;
++ __be16 pdst;
++ __u8 tos;
++};
++
++struct ethtool_ah_espip4_spec {
++ __be32 ip4src;
++ __be32 ip4dst;
++ __be32 spi;
++ __u8 tos;
++};
++
++#define ETHTOOL_GDRVINFO 0x00000003 /* Get driver info. */
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.876.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.876.ebuild
new file mode 100644
index 000000000000..2f34ac971b3b
--- /dev/null
+++ b/sys-block/open-iscsi/open-iscsi-2.0.876.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools versionator linux-info flag-o-matic toolchain-funcs udev systemd
+
+DESCRIPTION="A performant, transport independent, multi-platform implementation of RFC3720"
+HOMEPAGE="http://www.open-iscsi.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug infiniband +tcp rdma"
+
+DEPEND="sys-block/open-isns:=
+ infiniband? ( sys-fabric/ofed )
+ sys-kernel/linux-headers"
+RDEPEND="${DEPEND}
+ sys-fs/lsscsi
+ sys-apps/util-linux"
+REQUIRED_USE="infiniband? ( rdma ) || ( rdma tcp )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.876-musl-fixes.patch"
+ "${FILESDIR}/${PN}-2.0.876-Makefiles.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is -lt 2 6 16; then
+ die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
+ fi
+
+ # Needs to be done, as iscsid currently only starts, when having the iSCSI
+ # support loaded as module. Kernel builtin options don't work. See this for
+ # more information:
+ # https://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
+ # If there's a new release, check whether this is still valid!
+ TCP_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
+ RDMA_MODULES="INFINIBAND_ISER"
+ INFINIBAND_MODULES="INFINIBAND_IPOIB INIBAND_USER_MAD INFINIBAND_USER_ACCESS"
+ CONFIG_CHECK_MODULES="tcp? ( ${TCP_MODULES} ) rdma? ( ${RDMA_MODULES} ) infiniband? ( ${INFINIBAND_MODULES} )"
+ if linux_config_exists; then
+ if use tcp; then
+ for module in ${TCP_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
+ if use infiniband; then
+ for module in ${INFINIBAND_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
+ if use rdma; then
+ for module in ${RDMA_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"$
+ done
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -i -e 's:^\(iscsid.startup\)\s*=.*:\1 = /usr/sbin/iscsid:' etc/iscsid.conf || die
+ default
+
+ pushd iscsiuio >/dev/null || die
+ eautoreconf
+ popd >/dev/null || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+ append-lfs-flags
+}
+
+src_compile() {
+ # Stuffing CPPFLAGS into CFLAGS isn't entirely correct, but the build
+ # is messed up already here, so it's not making it that much worse.
+ KSRC="${KV_DIR}" CFLAGS="" \
+ emake \
+ OPTFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ AR="$(tc-getAR)" CC="$(tc-getCC)" \
+ user
+}
+
+src_install() {
+ emake DESTDIR="${ED}" sbindir="/usr/sbin" install
+ # Upstream make is not deterministic, per bug #601514
+ rm -f "${ED}"/etc/initiatorname.iscsi
+
+ dodoc README THANKS
+
+ docinto test/
+ dodoc test/*
+
+ insinto /etc/iscsi
+ newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example
+
+ newconfd "${FILESDIR}"/iscsid-conf.d iscsid
+ newinitd "${FILESDIR}"/iscsid-init.d iscsid
+
+ systemd_dounit "${S%/}"/etc/systemd/iscsid.service
+
+ keepdir /var/db/iscsi
+ fperms 700 /var/db/iscsi
+ fperms 600 /etc/iscsi/iscsid.conf
+}
+
+pkg_postinst() {
+ in='/etc/iscsi/initiatorname.iscsi'
+ if [ ! -f "${EROOT}${in}" -a -f "${EROOT}${in}.example" ]; then
+ {
+ cat "${EROOT}${in}.example"
+ echo "# InitiatorName generated by ${CATEGORY}/${PF} at $(date -uR)"
+ echo "InitiatorName=$(${ROOT}/usr/sbin/iscsi-iname)"
+ } >> "${EROOT}${in}.tmp" && mv -f "${EROOT}${in}.tmp" "${EROOT}${in}"
+ fi
+}