summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-10 23:18:14 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-10 23:21:26 +0100
commit29b7c0fd9b5f26244e0247fc1dc2af75aab87ed4 (patch)
tree495bea0c1463724ca716cad4a83f73658fbf1667 /sys-block
parentapp-arch/rar: drop old (diff)
downloadgentoo-29b7c0fd9b5f26244e0247fc1dc2af75aab87ed4.tar.gz
gentoo-29b7c0fd9b5f26244e0247fc1dc2af75aab87ed4.tar.bz2
gentoo-29b7c0fd9b5f26244e0247fc1dc2af75aab87ed4.zip
sys-block/mbuffer: bump to v20210209
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/mbuffer/Manifest1
-rw-r--r--sys-block/mbuffer/mbuffer-20210209.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-block/mbuffer/Manifest b/sys-block/mbuffer/Manifest
index 9eede0cede40..54fa2d5745fe 100644
--- a/sys-block/mbuffer/Manifest
+++ b/sys-block/mbuffer/Manifest
@@ -1,2 +1,3 @@
DIST mbuffer-20200505.tgz 146020 BLAKE2B b85742f710405e29775c7d25e9c1be733fd94d7157018017b7c8fb5b5cdeab7fa8819b024d297d96af960a73a8982fdeaefe50627c605f797df4d75b0c15435f SHA512 8a1e5721869fd705d02486cf93467bfe0a59b58789826ca337c18a023e9fbb18c1651211bfebdea4cdd45772ad23d0715bb3892bed04ce66f5fbe72406cde9f7
DIST mbuffer-20200929.tgz 147855 BLAKE2B abbcb4b29013ed24b4135a8b7576a0e728c3b5f1987558f0582711b1b00333caea8b55a02c4506ac179a4dae04977ee64572df09a210bf34bd71fd336be7e418 SHA512 332106205ea8743c9cf47529106c04ac15801a02b116d8e0c0fd3baadad51331c9f4ba1c8fa125edb42940cf401048a45ba23e2dac0e5189671bcf0ecee36996
+DIST mbuffer-20210209.tgz 147894 BLAKE2B ff6b1da468d34b1fef66178200f68998da0ef4042424845157afbd59e53dbef9e3d003ec9c1a663b28c0e3291d515841bb0a29dabf72a4dd781f6dde2b69b17d SHA512 82a3fd769c6935164db41dbc2e189fef27068c5d4604be923f42f6a9ba3dc3668e6918ba838a0015e9b5becde8b42c9268aa679e3aadb770c517873790f842d1
diff --git a/sys-block/mbuffer/mbuffer-20210209.ebuild b/sys-block/mbuffer/mbuffer-20210209.ebuild
new file mode 100644
index 000000000000..715e227db5dc
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20210209.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug libressl ssl test"
+
+REQUIRED_USE="test? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+ "${FILESDIR}/${PN}-20200929-find-OBJDUMP.patch"
+)
+
+src_prepare() {
+ ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+ default
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+ ewarn "Some tests may fail with FEATURES=usersandbox or"
+ ewarn "FEATURES=network-sandbox; Skipping tests because"
+ ewarn "test suite would hang forever in such environments!"
+ return 0;
+ fi
+
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ local -x MAKEOPTS=-j1
+
+ default
+}
+
+pkg_postinst() {
+ if ! has_version "app-arch/mt-st"; then
+ elog ""
+ elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+ fi
+}