summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-02 12:41:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-02 12:49:48 -0600
commit5e223b9de100d2ae29258aa8bc66637eff539fbf (patch)
tree35ab44c9e5fd559566c2ca61d2dd6d1554de78a0 /sys-block
parentdev-qt/qtprintsupport: arm stable, bug #598780 (diff)
downloadgentoo-5e223b9de100d2ae29258aa8bc66637eff539fbf.tar.gz
gentoo-5e223b9de100d2ae29258aa8bc66637eff539fbf.tar.bz2
gentoo-5e223b9de100d2ae29258aa8bc66637eff539fbf.zip
sys-block/open-isns: initial add for new release of open-iscsi-2.0.974
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-isns/Manifest1
-rw-r--r--sys-block/open-isns/metadata.xml10
-rw-r--r--sys-block/open-isns/open-isns-0.97.ebuild35
3 files changed, 46 insertions, 0 deletions
diff --git a/sys-block/open-isns/Manifest b/sys-block/open-isns/Manifest
new file mode 100644
index 000000000000..769f69f60c55
--- /dev/null
+++ b/sys-block/open-isns/Manifest
@@ -0,0 +1 @@
+DIST open-isns-0.97.tar.gz 278317 SHA256 c1c9ae740172e55a1ff33bc22151ec3d916562bf5d60c8420cd64496343683a9 SHA512 78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d WHIRLPOOL b69d99e883bfcc2b4f8c2cd8aeb0b3bc113eb0d7163de0b6d614815d6979de059d3ea8bc709590a211faf7c4cdbeefe823bd6c9bb077889c201f8c044a5bb832
diff --git a/sys-block/open-isns/metadata.xml b/sys-block/open-isns/metadata.xml
new file mode 100644
index 000000000000..50ad6c6916cb
--- /dev/null
+++ b/sys-block/open-isns/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-block/open-isns/open-isns-0.97.ebuild b/sys-block/open-isns/open-isns-0.97.ebuild
new file mode 100644
index 000000000000..fd746860ac16
--- /dev/null
+++ b/sys-block/open-isns/open-isns-0.97.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="iSNS server and client for Linux"
+HOMEPAGE="https://github.com/open-iscsi/open-isns"
+SRC_URI="http://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug slp ssl static"
+
+DEPEND="
+ ssl? ( dev-libs/openssl:= )
+ slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+ append-lfs-flags
+ econf $(use_with slp) \
+ $(use_with ssl security) \
+ $(use_enable !static shared)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_hdrs
+ emake DESTDIR="${D}" install_lib
+}