summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-02-19 18:21:22 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-19 18:21:22 -0800
commit7bbc54d939b14e626af57c9bf0a483efb75ce640 (patch)
tree711e8296ce938c2125dd3a67d1deb3bf552a2912 /sys-block
parentdev-python/snappy: Stabilize 0.6.0 arm64, #771477 (diff)
downloadgentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.tar.gz
gentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.tar.bz2
gentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.zip
sys-block/libzbc-5.9.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/libzbc/Manifest1
-rw-r--r--sys-block/libzbc/libzbc-5.9.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/libzbc/Manifest b/sys-block/libzbc/Manifest
index 582a2f9bcacc..223f12cb75df 100644
--- a/sys-block/libzbc/Manifest
+++ b/sys-block/libzbc/Manifest
@@ -1 +1,2 @@
DIST libzbc-5.5.1.tar.gz 128638 BLAKE2B 3cb636f29ff29bb87c86bd800231a1b45f517822e5785af599a6385705dffa1e90574e4bd2c1b310d5a0dab094cf6e878fc80b6178ea4eb028d5d1d174e7559a SHA512 cb060d06839ea207ed2e32e940348176dd0eff2279cbdb72f565bef177eb4a195feea67c4d1ed5f455e3839475e0f4557a45774129e3d9e009ea38f9134ae159
+DIST libzbc-5.9.0.tar.gz 131517 BLAKE2B eb05214ffea376930f1b4327152da687067023eab929ed1db123ea3bc80e0f036dfbe9889da2707f1c3842120d4fc3b2c8ab471731d45d5483fe947c21fc7cad SHA512 bcdf294d86867736826af06ad6d18dec31630b3f5bc6e3e98c228bec6a30efcce76a27e3c66a08ce670614ca016dc079894320cff340bafe126fcb40973e8302
diff --git a/sys-block/libzbc/libzbc-5.9.0.ebuild b/sys-block/libzbc/libzbc-5.9.0.ebuild
new file mode 100644
index 000000000000..41daf6685699
--- /dev/null
+++ b/sys-block/libzbc/libzbc-5.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A library and tools for working with ZBC and ZAC disks"
+HOMEPAGE="https://github.com/hgst/libzbc"
+SRC_URI="https://github.com/hgst/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND="
+ virtual/pkgconfig
+ >=sys-kernel/linux-headers-4.13
+ gtk? ( x11-libs/gtk+:3 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk gui) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}