summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-11-07 16:43:23 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2019-11-07 16:43:37 -0800
commite35496a92c76888f64aed8c64075bfc955626c82 (patch)
tree3c187f28c181b347982b4b622918b080e9d6b3ec /sys-block
parentsys-apps/rng-tools: bump to 6.8 (diff)
downloadgentoo-e35496a92c76888f64aed8c64075bfc955626c82.tar.gz
gentoo-e35496a92c76888f64aed8c64075bfc955626c82.tar.bz2
gentoo-e35496a92c76888f64aed8c64075bfc955626c82.zip
sys-block/scsiping: EAPI7 bump
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=697200 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..4879d3b7f737
--- /dev/null
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="https://www.vanheusden.com/Linux/"
+SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/strip scsiping/d' "${S}"/Makefile
+ default
+}
+
+src_compile() {
+ emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dosbin scsiping
+}
+
+pkg_postinst() {
+ ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}