summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2016-08-07 01:36:29 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 19:18:14 +0200
commitf9bfa20b5ca4393f975ebd6f70090d236a2da778 (patch)
tree3f9eb3588e6f02113ce22dc2b3d4ddc5ba815b0c /sys-block
parentdev-python/rtslib: add version 3.0_pre4 (diff)
downloadgentoo-f9bfa20b5ca4393f975ebd6f70090d236a2da778.tar.gz
gentoo-f9bfa20b5ca4393f975ebd6f70090d236a2da778.tar.bz2
gentoo-f9bfa20b5ca4393f975ebd6f70090d236a2da778.zip
sys-block/targetcli: add version 3.0_pre4
Gentoo-Bug: https://bugs.gentoo.org/453276 Reported-by: Andrew Hamilton <andrew@ahamilto.net> Closes: https://github.com/gentoo/gentoo/pull/2034 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/targetcli/Manifest1
-rw-r--r--sys-block/targetcli/targetcli-3.0_pre4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-block/targetcli/Manifest b/sys-block/targetcli/Manifest
new file mode 100644
index 000000000000..665728c8a869
--- /dev/null
+++ b/sys-block/targetcli/Manifest
@@ -0,0 +1 @@
+DIST targetcli-3.0_pre4.tar.gz 37299 SHA256 4f389c7de68f25034867770ecae45810340b33512dfae9827e5174db3408df88 SHA512 42e74fe8f7d26ad5693d6cd527d44d77b23f793b33071466819bf29032b71a6ad22924350fc53c78ed93c15ef30abb46b42209c5f16fbf8ade0819d6e26b70f7 WHIRLPOOL 5bb7f03a6fc0d56ab6a4197638dd7376eee1141e6e1f3f6c9e86ab307ff42ac5036a99de5fbdd42ba5708106c2098800d0d2b9af312fe08c72135e4f2a695b17
diff --git a/sys-block/targetcli/targetcli-3.0_pre4.ebuild b/sys-block/targetcli/targetcli-3.0_pre4.ebuild
new file mode 100644
index 000000000000..5701d51f4ee8
--- /dev/null
+++ b/sys-block/targetcli/targetcli-3.0_pre4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 linux-info
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/Datera/${PN}.git
+ https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ MY_PV=${PV/_/-}
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="CLI and shell for the Linux SCSI target"
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/configshell[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/rtslib[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/urwid[${PYTHON_USEDEP}]"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ linux-info_get_any_version
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel for SCSI target support"
+ else
+ CONFIG_CHECK="~TARGET_CORE"
+ check_extra_config
+ fi
+ fi
+}