summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-12 22:51:25 -0800
committerMatt Turner <mattst88@gentoo.org>2019-11-12 22:53:14 -0800
commitfb58e8da0267a7e72ffdcf20b2ba48c92ea1b2d6 (patch)
tree2f1e6efa8e00698bb75f7f64641145dbcd3016f4 /sys-boot/aboot
parentsys-boot/milo: Port to EAPI=7 (diff)
downloadgentoo-fb58e8da0267a7e72ffdcf20b2ba48c92ea1b2d6.tar.gz
gentoo-fb58e8da0267a7e72ffdcf20b2ba48c92ea1b2d6.tar.bz2
gentoo-fb58e8da0267a7e72ffdcf20b2ba48c92ea1b2d6.zip
sys-boot/aboot: Port to EAPI=7
Closes: https://bugs.gentoo.org/697182 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-boot/aboot')
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
index d6c38443b2c4..cba6251a37af 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
@@ -30,18 +30,20 @@ src_unpack() {
cd "${S}"/include
ln -s asm-alpha asm || die
touch linux/config.h || die
- cd "${S}"
- epatch "${FILESDIR}/aboot-gcc-3.4.patch"
- epatch "${FILESDIR}/aboot-pt_note.patch"
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/aboot-gcc-3.4.patch"
+ eapply "${FILESDIR}/aboot-pt_note.patch"
# Bug 364697
- epatch "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
- epatch "${FILESDIR}"/aboot-respect-AR.patch
- epatch "${FILESDIR}"/aboot-gnu90.patch
+ eapply "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
+ eapply "${FILESDIR}"/aboot-respect-AR.patch
+ eapply "${FILESDIR}"/aboot-gnu90.patch
# Modified patch from Debian to add netboot support
- epatch "${WORKDIR}"/aboot_gentoo.diff
+ eapply "${WORKDIR}"/aboot_gentoo.diff
- epatch_user
+ eapply_user
}
src_compile() {