summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-07 14:28:57 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-07 14:28:57 -0500
commite7ec64e07c110fd117d37b26c7ca668eba586f9a (patch)
treec48d170efe100c8c078c5f4965d120ac0b098311 /sys-boot/lilo/lilo-24.0-r1.ebuild
parentdev-libs/openssl: Security cleanup (diff)
downloadgentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.tar.gz
gentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.tar.bz2
gentoo-e7ec64e07c110fd117d37b26c7ca668eba586f9a.zip
sys-boot/lilo: remove legacy HARDENED_CFLAGS, bug #621866
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-boot/lilo/lilo-24.0-r1.ebuild')
-rw-r--r--sys-boot/lilo/lilo-24.0-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/sys-boot/lilo/lilo-24.0-r1.ebuild b/sys-boot/lilo/lilo-24.0-r1.ebuild
index 4de878e34d33..b0639924ba39 100644
--- a/sys-boot/lilo/lilo-24.0-r1.ebuild
+++ b/sys-boot/lilo/lilo-24.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -49,10 +49,6 @@ src_compile() {
# lilo needs this. bug #140209
export LC_ALL=C
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS=$(test-flags-CC -fno-pic -nopie)
-
# we explicitly prevent the custom CFLAGS for stability reasons
if use static; then
local target=alles
@@ -60,7 +56,7 @@ src_compile() {
local target=all
fi
- emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" ${target} || die
+ emake CC="$(tc-getCC) ${LDFLAGS}" ${target} || die
}
src_install() {