summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2020-07-31 00:08:05 -0400
committerJoshua Kinard <kumba@gentoo.org>2020-07-31 00:08:45 -0400
commitd5f9c57fe506f3c38fa8b4e939fc1c1a28c621a2 (patch)
treec043b93c1842d72cd0d2bc87e0becb0b3d63fdd9 /sys-boot/lilo/lilo-24.2.ebuild
parentwww-misc/shellinabox: ppc64 stable (bug #733488) (diff)
downloadgentoo-d5f9c57fe506f3c38fa8b4e939fc1c1a28c621a2.tar.gz
gentoo-d5f9c57fe506f3c38fa8b4e939fc1c1a28c621a2.tar.bz2
gentoo-d5f9c57fe506f3c38fa8b4e939fc1c1a28c621a2.zip
sys-boot/lilo: EAPI 7 and add NVME support
Signed-off-by: Joshua Kinard <kumba@gentoo.org> Closes: https://bugs.gentoo.org/689940 Package-Manager: Portage-3.0.1, Repoman-2.3.23
Diffstat (limited to 'sys-boot/lilo/lilo-24.2.ebuild')
-rw-r--r--sys-boot/lilo/lilo-24.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-boot/lilo/lilo-24.2.ebuild b/sys-boot/lilo/lilo-24.2.ebuild
index c84d6257d959..73f9ea6efbb4 100644
--- a/sys-boot/lilo/lilo-24.2.ebuild
+++ b/sys-boot/lilo/lilo-24.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit eutils flag-o-matic toolchain-funcs
@@ -25,10 +25,14 @@ DEPEND=">=sys-devel/bin86-0.15.5"
RDEPEND="device-mapper? ( >=sys-fs/lvm2-2.02.45 )"
src_prepare() {
+ default
+
# this patch is needed when booting PXE and the device you're using
# emulates vga console via serial console.
# IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
- use pxeserial && epatch "${FILESDIR}/${PN}-24.1-novga.patch"
+ use pxeserial && eapply "${FILESDIR}/${PN}-24.1-novga.patch"
+
+ eapply "${FILESDIR}/${PN}-24.2-add-nvme-support.patch"
# Do not strip and have parallel make
# FIXME: images/Makefile does weird stuff