summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-10 10:43:16 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-10 10:43:16 +0200
commit04a10ed311201d252062abf1c5243bec236bb563 (patch)
tree6daad75334e8fdfb3aa3d43bb0a99d50d6093614 /sys-boot/palo/files
parentsys-boot/palo: Version bump. (diff)
downloadgentoo-04a10ed311201d252062abf1c5243bec236bb563.tar.gz
gentoo-04a10ed311201d252062abf1c5243bec236bb563.tar.bz2
gentoo-04a10ed311201d252062abf1c5243bec236bb563.zip
sys-boot/palo: Fix toolchain patch.
Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-boot/palo/files')
-rw-r--r--sys-boot/palo/files/palo-1.96-toolchain.patch22
1 files changed, 21 insertions, 1 deletions
diff --git a/sys-boot/palo/files/palo-1.96-toolchain.patch b/sys-boot/palo/files/palo-1.96-toolchain.patch
index e0ea92643509..5b9e792bf049 100644
--- a/sys-boot/palo/files/palo-1.96-toolchain.patch
+++ b/sys-boot/palo/files/palo-1.96-toolchain.patch
@@ -1,6 +1,26 @@
--- a/palo/Makefile
+++ b/palo/Makefile
-@@ -34,7 +33,7 @@
+@@ -10,9 +10,9 @@
+ OS := $(shell uname -s)
+ CC?=cc
+ ifeq ($(strip ${OS}),HP-UX)
+-CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
++CFLAGS=-O -I../include -I../lib -I$(PA)/include
+ else
+-CFLAGS=-g -O -I../include -I../lib -D_FILE_OFFSET_BITS=64
++CFLAGS=-O -I../include -I../lib -D_FILE_OFFSET_BITS=64
+ endif
+
+ ifneq ("$(wildcard /etc/debian_version)","")
+@@ -22,7 +22,6 @@
+ endif
+
+ # LDFLAGS=-Wl,-Bstatic
+-LDFLAGS=
+
+ OFILES2=mkbootable.o elf64.o load.o paloio.o elf32.o error.o gzip.o
+
+@@ -38,7 +37,7 @@
$(CC) $(CFLAGS) $(LDFLAGS) -o palo palo.a build.o
palo.a: $(OFILES)